aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/ftplocate/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-12-25 13:04:31 +0800
committersteve <steve@FreeBSD.org>1999-12-25 13:04:31 +0800
commite8c29ee001477f969cc83e374a9512d3cbf10b05 (patch)
treef7bbb43da6b96dabef10a2e3aba48bace45b0c94 /ftp/ftplocate/Makefile
parentd4c8de218a9b5d9c90294382896fb4b18f27a0ac (diff)
downloadfreebsd-ports-gnome-e8c29ee001477f969cc83e374a9512d3cbf10b05.tar.gz
freebsd-ports-gnome-e8c29ee001477f969cc83e374a9512d3cbf10b05.tar.zst
freebsd-ports-gnome-e8c29ee001477f969cc83e374a9512d3cbf10b05.zip
Adding ftplocate version 1.50.
An ftp search engine supporting filename and description search. PR: 15332 Submitted by: Chung-Kie Tung <tung@turtle.ee.ncku.edu.tw>
Diffstat (limited to 'ftp/ftplocate/Makefile')
-rw-r--r--ftp/ftplocate/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/ftp/ftplocate/Makefile b/ftp/ftplocate/Makefile
new file mode 100644
index 000000000000..16a12fd64b87
--- /dev/null
+++ b/ftp/ftplocate/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: Ftplocate
+# Version required: 1.50
+# Date created: 7 December 1999
+# Whom: tung@turtle.ee.ncku.edu.tw
+#
+# $FreeBSD$
+#
+
+DISTNAME= ftplocate-1.50
+CATEGORIES= ftp www
+MASTER_SITES= ftp://ftp.ee.ncku.edu.tw/pub/
+
+MAINTAINER= tung@turtle.ee.ncku.edu.tw
+
+RUN_DEPENDS+= glimpse:${PORTSDIR}/textproc/glimpse
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL} -d ${PREFIX}/www/cgi-bin/ftplocate \
+ ${PREFIX}/www/cgi-bin/ftplocate/index \
+ ${PREFIX}/www/cgi-bin/ftplocate/desc
+ ${INSTALL} -o nobody -g nobody -m 755 -d ${PREFIX}/www/cgi-bin/ftplocate/cache
+ cd ${WRKSRC}; \
+ ${INSTALL_DATA} \
+ README README.zhtw fl.english fl.zhtw \
+ ${PREFIX}/www/cgi-bin/ftplocate ;\
+ ${INSTALL} -c -m 644 \
+ fl.config fl.share \
+ ${PREFIX}/www/cgi-bin/ftplocate ;\
+ ${INSTALL_SCRIPT} \
+ dcollect.pl dindex.pl flcollect.pl flindex.pl indexer.sh \
+ flfilter.pl flsearch.pl dsearch.pl flserv.pl flhistory.pl \
+ ${PREFIX}/www/cgi-bin/ftplocate ;\
+ ${INSTALL_DATA} \
+ flhelp.html flhelp.zhtw.html \
+ ${PREFIX}/www/data ;\
+ ${INSTALL_SCRIPT} ftplocate ${PREFIX}/bin/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>