aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/ftplocate
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-01-30 05:23:44 +0800
committersteve <steve@FreeBSD.org>2000-01-30 05:23:44 +0800
commit5219af68a4bd07658440f20f77ebba6a73aa87d5 (patch)
treebbca8b0e42f890a218aa437c7e99966702d4fe96 /ftp/ftplocate
parent4fd0470d8df23d14fd2c6a7ed976963ff526cd6a (diff)
downloadfreebsd-ports-gnome-5219af68a4bd07658440f20f77ebba6a73aa87d5.tar.gz
freebsd-ports-gnome-5219af68a4bd07658440f20f77ebba6a73aa87d5.tar.zst
freebsd-ports-gnome-5219af68a4bd07658440f20f77ebba6a73aa87d5.zip
Make sure we use the correct path to perl(1).
PR: 16202
Diffstat (limited to 'ftp/ftplocate')
-rw-r--r--ftp/ftplocate/Makefile16
-rw-r--r--ftp/ftplocate/pkg-plist1
2 files changed, 13 insertions, 4 deletions
diff --git a/ftp/ftplocate/Makefile b/ftp/ftplocate/Makefile
index a96150bf835e..d1052278054b 100644
--- a/ftp/ftplocate/Makefile
+++ b/ftp/ftplocate/Makefile
@@ -17,6 +17,14 @@ RUN_DEPENDS+= glimpse:${PORTSDIR}/textproc/glimpse
USE_PERL5= yes
NO_BUILD= yes
+PL_FILES= dcollect.pl dindex.pl dsearch.pl flcollect.pl flfilter.pl \
+ flhistory.pl flindex.pl flsearch.pl flserv.pl fltrain.pl
+
+post-extract:
+.for f in ${PL_FILES}
+ @${PERL} -pi -e 's,/usr/local/bin/perl,${PERL},' ${WRKSRC}/${f}
+.endfor
+
do-install:
${INSTALL} -d ${PREFIX}/www/cgi-bin/ftplocate \
${PREFIX}/www/cgi-bin/ftplocate/index \
@@ -30,14 +38,14 @@ do-install:
${INSTALL} -c -m 644 \
fl.config fl.share \
${PREFIX}/www/cgi-bin/ftplocate ;\
- ${INSTALL_SCRIPT} \
- dcollect.pl dindex.pl flcollect.pl flindex.pl indexer.sh \
- flfilter.pl flsearch.pl dsearch.pl flserv.pl flhistory.pl \
- ${PREFIX}/www/cgi-bin/ftplocate ;\
+ ${INSTALL_SCRIPT} indexer.sh ${PREFIX}/www/cgi-bin/ftplocate; \
${INSTALL_DATA} \
flhelp.html flhelp.zhtw.html \
${PREFIX}/www/data ;\
${INSTALL_SCRIPT} ftplocate ${PREFIX}/bin/
+.for f in ${PL_FILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/www/cgi-bin/ftplocate
+.endfor
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/ftp/ftplocate/pkg-plist b/ftp/ftplocate/pkg-plist
index 3e3b86c9e763..d8b2010b59ba 100644
--- a/ftp/ftplocate/pkg-plist
+++ b/ftp/ftplocate/pkg-plist
@@ -14,6 +14,7 @@ www/cgi-bin/ftplocate/flhistory.pl
www/cgi-bin/ftplocate/flindex.pl
www/cgi-bin/ftplocate/flsearch.pl
www/cgi-bin/ftplocate/flserv.pl
+www/cgi-bin/ftplocate/fltrain.pl
www/cgi-bin/ftplocate/indexer.sh
www/data/flhelp.html
www/data/flhelp.zhtw.html