aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/ftpproxy
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-26 04:47:31 +0800
committerbapt <bapt@FreeBSD.org>2014-01-26 04:47:31 +0800
commita403f7fd8405ff36a4e52863e5a81827ab4d56da (patch)
treee147f2219e15ecde91ec9e69eec30dc1dc17e0c5 /ftp/ftpproxy
parent5935325c093d0d4f5989fd49f9d28d183997aa64 (diff)
downloadfreebsd-ports-gnome-a403f7fd8405ff36a4e52863e5a81827ab4d56da.tar.gz
freebsd-ports-gnome-a403f7fd8405ff36a4e52863e5a81827ab4d56da.tar.zst
freebsd-ports-gnome-a403f7fd8405ff36a4e52863e5a81827ab4d56da.zip
Support stage
Respect CC USE_GMAKE -> USES=gmake
Diffstat (limited to 'ftp/ftpproxy')
-rw-r--r--ftp/ftpproxy/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/ftp/ftpproxy/Makefile b/ftp/ftpproxy/Makefile
index 9a153aa0e8da..e5c1982aeebf 100644
--- a/ftp/ftpproxy/Makefile
+++ b/ftp/ftpproxy/Makefile
@@ -10,22 +10,21 @@ MASTER_SITES= http://www.ftpproxy.org/download/ \
EXTRACT_SUFX= .tgz
MAINTAINER= philippe@le-berre.com
-COMMENT= A ftp proxy
+COMMENT= ftp proxy
-USE_GMAKE= yes
+USES= gmake
MAKE_JOBS_UNSAFE= yes
+MAKE_ARGS= CC=${CC}
-MAN1= ftp.proxy.1
-MANCOMPRESSED= no
-PLIST_FILES= sbin/ftp.proxy
+PLIST_FILES= sbin/ftp.proxy \
+ man/man1/ftp.proxy.1.gz
-NO_STAGE= yes
pre-build:
@${REINPLACE_CMD} -e 's|^CFLAGS.*|CFLAGS=${CFLAGS} \
-DVERSION=\\"${PORTVERSION}\\"|' ${WRKSRC}/src/Makefile
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/src/ftp.proxy ${PREFIX}/sbin
- @${INSTALL_MAN} ${WRKSRC}/doc/ftp.proxy.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ftp.proxy ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/doc/ftp.proxy.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>