aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/ftpsync
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-04-04 16:14:04 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-04-04 16:14:04 +0800
commit26a5c647512df8370d6b880bcabcf86a8c52ceae (patch)
tree50f513dc121dfb81633ad5dbede40f8c69d7bf5b /ftp/ftpsync
parent270f30bfb04459b68a3cc6e3580496f52585f7bc (diff)
downloadfreebsd-ports-gnome-26a5c647512df8370d6b880bcabcf86a8c52ceae.tar.gz
freebsd-ports-gnome-26a5c647512df8370d6b880bcabcf86a8c52ceae.tar.zst
freebsd-ports-gnome-26a5c647512df8370d6b880bcabcf86a8c52ceae.zip
- Support staging
- Use shebangfix - Convert USE_BZIP2=yes to USES=tar:bzip2
Diffstat (limited to 'ftp/ftpsync')
-rw-r--r--ftp/ftpsync/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/ftp/ftpsync/Makefile b/ftp/ftpsync/Makefile
index a3545c67cbfc..0afefdc1f921 100644
--- a/ftp/ftpsync/Makefile
+++ b/ftp/ftpsync/Makefile
@@ -13,19 +13,18 @@ COMMENT= Synchronizes a local and a remote FTP directory trees
RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww
+USES= perl5 tar:bzip2 shebangfix
NO_BUILD= yes
-USE_BZIP2= yes
-USES= perl5
+
PLIST_FILES= bin/${PORTNAME}.pl
+SHEBANG_FILES= ftpsync.pl
PORTDOCS= README
-NO_STAGE= yes
-do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/
+OPTIONS_DEFINE= DOCS
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
-.endif
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>