aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/gwget
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /ftp/gwget
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'ftp/gwget')
-rw-r--r--ftp/gwget/Makefile4
-rw-r--r--ftp/gwget/files/patch-src_systray.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
index 921e892f1e14..760bedad7565 100644
--- a/ftp/gwget/Makefile
+++ b/ftp/gwget/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gwget
PORTVERSION= 1.0.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= ftp gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -36,7 +36,7 @@ GCONF_SCHEMAS= ${PORTNAME}.schemas
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_LIBNOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
.else
CONFIGURE_ARGS+= --disable-libnotify
diff --git a/ftp/gwget/files/patch-src_systray.c b/ftp/gwget/files/patch-src_systray.c
new file mode 100644
index 000000000000..038269360272
--- /dev/null
+++ b/ftp/gwget/files/patch-src_systray.c
@@ -0,0 +1,11 @@
+--- src/systray.c.orig 2011-08-16 13:49:31.000000000 +0200
++++ src/systray.c 2011-08-16 13:49:44.000000000 +0200
+@@ -224,7 +224,7 @@ gwget_tray_notify (gchar *primary, gchar
+ if (!notify_is_initted ())
+ if (!notify_init ("gwget"))
+ return;
+- NotifyNotification *notification = notify_notification_new(primary,secondary,icon_name,NULL);
++ NotifyNotification *notification = notify_notification_new(primary,secondary,icon_name);
+ notify_notification_show(notification,NULL);
+ #endif
+