aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/libfxp/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-22 00:13:17 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-22 00:13:17 +0800
commitc892af1780b67e6fdabc7f4945bcad3d9e29571d (patch)
tree8a9971c8edf6533234e79b9a5cc3a411a279b46f /ftp/libfxp/Makefile
parent37a43dfd3cd3a54cc3207c6a319b0e292b80f6fd (diff)
downloadfreebsd-ports-gnome-c892af1780b67e6fdabc7f4945bcad3d9e29571d.tar.gz
freebsd-ports-gnome-c892af1780b67e6fdabc7f4945bcad3d9e29571d.tar.zst
freebsd-ports-gnome-c892af1780b67e6fdabc7f4945bcad3d9e29571d.zip
Replace ${PERL} with ${REINPLACE_CMD}
PR: 39594 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'ftp/libfxp/Makefile')
-rw-r--r--ftp/libfxp/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/ftp/libfxp/Makefile b/ftp/libfxp/Makefile
index 6fa900a58867..477f2cfe2121 100644
--- a/ftp/libfxp/Makefile
+++ b/ftp/libfxp/Makefile
@@ -13,17 +13,18 @@ MASTER_SITES= http://millweed.com/projects/libfxp/
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_GMAKE= yes
CFLAGS+= -I. -Ilibmillweed
post-patch:
.for file in Makefile libmillweed/Makefile
- @${PERL} -pi -e "s,^CC,#CC,g ; \
+ @${REINPLACE_CMD} -e "s,^CC,#CC,g ; \
s,^CFLAGS,#CFLAGS,g ; \
s,^PREFIX,#PREFIX,g" ${WRKSRC}/${file}
.endfor
@(cd ${WRKSRC} ; \
${GREP} -l -R malloc.h * | xargs \
- ${PERL} -pi -e "s|malloc.h|stdlib.h|g")
+ ${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g")
.include <bsd.port.mk>