aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/linux-curl/Makefile
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-08-04 22:38:03 +0800
committeracm <acm@FreeBSD.org>2006-08-04 22:38:03 +0800
commite3e2191bbd7bfaa997a88d05fa519836315e656e (patch)
tree37494c625460cc049807b13b1a408acaacc3942b /ftp/linux-curl/Makefile
parentfbb3370bb7809d90f8dcbae979c433f8f6f2d0b0 (diff)
downloadfreebsd-ports-gnome-e3e2191bbd7bfaa997a88d05fa519836315e656e.tar.gz
freebsd-ports-gnome-e3e2191bbd7bfaa997a88d05fa519836315e656e.tar.zst
freebsd-ports-gnome-e3e2191bbd7bfaa997a88d05fa519836315e656e.zip
- New port: ftp/linux-curl
curl is a client to get documents/files from servers, using any of the supported protocols. The command is designed to work without user interaction or any kind of interactivity. curl offers a busload of useful tricks like proxy support, user authentication, ftp upload, HTTP post, SSL (https:) connections, file transfer resume and more. (Linux version) WWW: http://curl.haxx.se/ Approved by: garga (mentor)
Diffstat (limited to 'ftp/linux-curl/Makefile')
-rw-r--r--ftp/linux-curl/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/ftp/linux-curl/Makefile b/ftp/linux-curl/Makefile
new file mode 100644
index 000000000000..a153aec73284
--- /dev/null
+++ b/ftp/linux-curl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: linux-curl
+# Date created: 2006-08-04
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= curl
+PORTVERSION= 7.13.1
+CATEGORIES= ftp linux
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-5.fc4
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Curl linux version
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 4
+INSTALLS_SHLIB= yes
+AUTOMATIC_PLIST= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>