aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/moftpd/Makefile
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-06-12 05:42:16 +0800
committerclement <clement@FreeBSD.org>2004-06-12 05:42:16 +0800
commitbe87b3195515274a38ecd465c8e2c5c3cdb0acd4 (patch)
tree46b2d24ab1cfd18ffb6fd3c2ef76d99515b41597 /ftp/moftpd/Makefile
parentd877d5c7bec2d378a4d8938bed9668a5a68d90f9 (diff)
downloadfreebsd-ports-gnome-be87b3195515274a38ecd465c8e2c5c3cdb0acd4.tar.gz
freebsd-ports-gnome-be87b3195515274a38ecd465c8e2c5c3cdb0acd4.tar.zst
freebsd-ports-gnome-be87b3195515274a38ecd465c8e2c5c3cdb0acd4.zip
- Add RCng startup script
Diffstat (limited to 'ftp/moftpd/Makefile')
-rw-r--r--ftp/moftpd/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/ftp/moftpd/Makefile b/ftp/moftpd/Makefile
index aba61efae4ec..7ca3f6082271 100644
--- a/ftp/moftpd/Makefile
+++ b/ftp/moftpd/Makefile
@@ -18,10 +18,14 @@ COMMENT= A powerful FTP server supporting IPv6, TLS, and much more
GNU_CONFIGURE= yes
USE_OPENSSL= yes
USE_GMAKE= yes
+USE_RC_SUBR= yes
USE_PERL5_BUILD=yes
CONFIGURE_ENV+= LIBS="${LIBS}"
+CONFIGURE_ARGS= --localstatedir=/var
+
MAN8= moftpd.8 moftpadmin.8
LIBS+= -lcrypt
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
.if defined(WITH_MYSQL)
CFLAGS+= -I${LOCALBASE}/include
@@ -30,4 +34,11 @@ LIBS+= -L${LOCALBASE}/lib/mysql
CONFIGURE_ARGS+= --without-sql
.endif
+post-patch:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/moftpd.sh > ${WRKDIR}/moftpd.sh
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/moftpd.sh ${PREFIX}/etc/rc.d/
+
.include <bsd.port.mk>