aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/multiget
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-12-08 02:01:00 +0800
committeralepulver <alepulver@FreeBSD.org>2006-12-08 02:01:00 +0800
commited16b3e7af41ab68d57772bf6736b9806d0e6d51 (patch)
tree91ee759a61afea6ca7ac2eb92bb591aa5729b42a /ftp/multiget
parent846f4c27be1c5a98d595e79aa6444873ebcc64da (diff)
downloadfreebsd-ports-gnome-ed16b3e7af41ab68d57772bf6736b9806d0e6d51.tar.gz
freebsd-ports-gnome-ed16b3e7af41ab68d57772bf6736b9806d0e6d51.tar.zst
freebsd-ports-gnome-ed16b3e7af41ab68d57772bf6736b9806d0e6d51.zip
MultiGet is an easy-to-use GUI file downloader for Linux/Unix/BSDs/Windows.
It's programmed by C++ and GUI is based on wxWidgets. It supports http/ftp protocol which covers most user's requirement. It supports multi-task with multi-thread on multi-server. It supports resume download if server side have resume feature, and if you like, you can reconfig the thread number without stopping the going task. It's also support SOCKS 4, 4a, 5 proxy, ftp proxy, http proxy. WWW: http://multiget.sourceforge.net/
Diffstat (limited to 'ftp/multiget')
-rw-r--r--ftp/multiget/Makefile43
-rw-r--r--ftp/multiget/distinfo3
-rw-r--r--ftp/multiget/files/patch-mgsocket.h10
-rw-r--r--ftp/multiget/pkg-descr9
4 files changed, 65 insertions, 0 deletions
diff --git a/ftp/multiget/Makefile b/ftp/multiget/Makefile
new file mode 100644
index 000000000000..1a96930b62df
--- /dev/null
+++ b/ftp/multiget/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: multiget
+# Date created: 2006-11-03
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= multiget
+PORTVERSION= 1.0
+CATEGORIES= ftp www
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}${PORTVERSION}.src
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= An http/ftp downloader with a nice GUI
+
+USE_BZIP2= yes
+USE_WX= 2.6
+MAKEFILE= makefile
+ALL_TARGET= MultiGet
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/src
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|g++|${CXX}|; \
+ s|\(CFLAGS\) =|\1 +=|; \
+ s|wx-config|${WX_CONFIG}|' \
+ ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -Ee 's,(fopen|ftruncate)64,\1,' \
+ ${WRKSRC}/mgfilemanager.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/MultiGet ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/multiget/distinfo b/ftp/multiget/distinfo
new file mode 100644
index 000000000000..1a844b8a0589
--- /dev/null
+++ b/ftp/multiget/distinfo
@@ -0,0 +1,3 @@
+MD5 (multiget1.0.src.tar.bz2) = a30f15408079289e49ad0ea249075261
+SHA256 (multiget1.0.src.tar.bz2) = 2cfeca1fe2833db678505f1a318fc1d32f8f09b2da141b0739a1b9456505f493
+SIZE (multiget1.0.src.tar.bz2) = 577376
diff --git a/ftp/multiget/files/patch-mgsocket.h b/ftp/multiget/files/patch-mgsocket.h
new file mode 100644
index 000000000000..0daa2661ad5f
--- /dev/null
+++ b/ftp/multiget/files/patch-mgsocket.h
@@ -0,0 +1,10 @@
+--- ./mgsocket.h.orig Sat Nov 4 05:04:00 2006
++++ ./mgsocket.h Wed Dec 6 14:02:01 2006
+@@ -30,6 +30,7 @@
+ #else
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <unistd.h>
+ #include <sys/un.h>
diff --git a/ftp/multiget/pkg-descr b/ftp/multiget/pkg-descr
new file mode 100644
index 000000000000..31e3d7e22ae1
--- /dev/null
+++ b/ftp/multiget/pkg-descr
@@ -0,0 +1,9 @@
+MultiGet is an easy-to-use GUI file downloader for Linux/Unix/BSDs/Windows.
+It's programmed by C++ and GUI is based on wxWidgets. It supports http/ftp
+protocol which covers most user's requirement. It supports multi-task with
+multi-thread on multi-server. It supports resume download if server side have
+resume feature, and if you like, you can reconfig the thread number without
+stopping the going task. It's also support SOCKS 4, 4a, 5 proxy, ftp proxy,
+http proxy.
+
+WWW: http://multiget.sourceforge.net/