aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/p5-Net-FTPSSL
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-02 21:55:59 +0800
committerwen <wen@FreeBSD.org>2010-12-02 21:55:59 +0800
commitd9f788638f25e5c96635070f091ef6853c086b87 (patch)
tree3e79157a2325a815ef30bcd1b1fbe33027c19a0f /ftp/p5-Net-FTPSSL
parentca09d880708f341d2f1e5f3f20a77292c1ed6778 (diff)
downloadfreebsd-ports-gnome-d9f788638f25e5c96635070f091ef6853c086b87.tar.gz
freebsd-ports-gnome-d9f788638f25e5c96635070f091ef6853c086b87.tar.zst
freebsd-ports-gnome-d9f788638f25e5c96635070f091ef6853c086b87.zip
Net::FTPSSL is a class implementing a simple FTP client over a Secure
Sockets Layer (SSL) or Transport Layer Security (TLS) connection written in Perl as described in RFC959 and RFC2228. It will use TLS by default. WWW: http://search.cpan.org/dist/Net-FTPSSL/
Diffstat (limited to 'ftp/p5-Net-FTPSSL')
-rw-r--r--ftp/p5-Net-FTPSSL/Makefile25
-rw-r--r--ftp/p5-Net-FTPSSL/distinfo2
-rw-r--r--ftp/p5-Net-FTPSSL/pkg-descr5
-rw-r--r--ftp/p5-Net-FTPSSL/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/ftp/p5-Net-FTPSSL/Makefile b/ftp/p5-Net-FTPSSL/Makefile
new file mode 100644
index 000000000000..2591291832b3
--- /dev/null
+++ b/ftp/p5-Net-FTPSSL/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-FTPSSL
+# Date created: 1st Dec, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-FTPSSL
+PORTVERSION= 0.16
+CATEGORIES= ftp perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A FTP over SSL/TLS class
+
+BUILD_DEPENDS= p5-IO-Socket-SSL>=1.08:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::FTPSSL.3
+
+.include <bsd.port.mk>
diff --git a/ftp/p5-Net-FTPSSL/distinfo b/ftp/p5-Net-FTPSSL/distinfo
new file mode 100644
index 000000000000..49c4ad472552
--- /dev/null
+++ b/ftp/p5-Net-FTPSSL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-FTPSSL-0.16.tar.gz) = dbcc518e4872bc26cf9b9dd271a9750bbf31b6fcb7128616663398cdf473c8a8
+SIZE (Net-FTPSSL-0.16.tar.gz) = 46111
diff --git a/ftp/p5-Net-FTPSSL/pkg-descr b/ftp/p5-Net-FTPSSL/pkg-descr
new file mode 100644
index 000000000000..6556ccc90db4
--- /dev/null
+++ b/ftp/p5-Net-FTPSSL/pkg-descr
@@ -0,0 +1,5 @@
+Net::FTPSSL is a class implementing a simple FTP client over a Secure
+Sockets Layer (SSL) or Transport Layer Security (TLS) connection written
+in Perl as described in RFC959 and RFC2228. It will use TLS by default.
+
+WWW: http://search.cpan.org/dist/Net-FTPSSL/
diff --git a/ftp/p5-Net-FTPSSL/pkg-plist b/ftp/p5-Net-FTPSSL/pkg-plist
new file mode 100644
index 000000000000..5ac32e03804e
--- /dev/null
+++ b/ftp/p5-Net-FTPSSL/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Net/FTPSSL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FTPSSL/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FTPSSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net