aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/phpwebftp
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-04 02:09:23 +0800
committeradamw <adamw@FreeBSD.org>2014-07-04 02:09:23 +0800
commitc0eeb18438c4516f6a908d609e68b636c5d8c852 (patch)
treebebe55e16ba76208927dd87d2beb187237f7af27 /ftp/phpwebftp
parentce17bac993d4a6624148ab3ecf234efb6b041b8d (diff)
downloadfreebsd-ports-gnome-c0eeb18438c4516f6a908d609e68b636c5d8c852.tar.gz
freebsd-ports-gnome-c0eeb18438c4516f6a908d609e68b636c5d8c852.tar.zst
freebsd-ports-gnome-c0eeb18438c4516f6a908d609e68b636c5d8c852.zip
Stage.
Diffstat (limited to 'ftp/phpwebftp')
-rw-r--r--ftp/phpwebftp/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/ftp/phpwebftp/Makefile b/ftp/phpwebftp/Makefile
index a53e5413dff4..9f78c16afbc9 100644
--- a/ftp/phpwebftp/Makefile
+++ b/ftp/phpwebftp/Makefile
@@ -20,14 +20,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALL_DIRE= ${INSTALL} -d -m 0755 -o ${WWWOWN} -g ${WWWGRP}
INSTALL_FILE= ${INSTALL} -m 0644 -o ${WWWOWN} -g ${WWWGRP}
-NO_STAGE= yes
post-extract:
@${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -R "{}" \;
do-install:
${INSTALL_DIRE} ${PREFIX}/${PHPWEBFTPDIR}
- @cd ${WRKSRC} && \
- ${FIND} * -type d -exec ${INSTALL_DIRE} "${PREFIX}/${PHPWEBFTPDIR}/{}" \; && \
+ (cd ${WRKSRC} && \
+ ${FIND} * -type d -exec ${INSTALL_DIRE} "${STAGEDIR}${PREFIX}/${PHPWEBFTPDIR}/{}" \; && \
${FIND} -E * -type f -iregex ".*\.(php|html|css|gif|js)" \
- -exec ${INSTALL_FILE} "{}" "${PREFIX}/${PHPWEBFTPDIR}/{}" \;
+ -exec ${INSTALL_FILE} "{}" "${STAGEDIR}${PREFIX}/${PHPWEBFTPDIR}/{}" \;)
.include <bsd.port.mk>