aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-03-28 03:36:11 +0800
committerbeech <beech@FreeBSD.org>2008-03-28 03:36:11 +0800
commitecbf8e1d8483217a5eb91e81612d9f7ba05cded8 (patch)
treed8d70045b14ab497af2733284e91d8bf31856242 /ftp/proftpd/Makefile
parent1e24895eb92fd76244f5b10d1ec5f0aa3459ee70 (diff)
downloadfreebsd-ports-gnome-ecbf8e1d8483217a5eb91e81612d9f7ba05cded8.tar.gz
freebsd-ports-gnome-ecbf8e1d8483217a5eb91e81612d9f7ba05cded8.tar.zst
freebsd-ports-gnome-ecbf8e1d8483217a5eb91e81612d9f7ba05cded8.zip
- Re-add OPTIONS CODECONV (mod_codeconv) with v1.3.1 fixes for international users
- Bump portrevision Submitted by: Alexey V. Drozdov <nyquist@ctam.tu-bryansk.ru>
Diffstat (limited to 'ftp/proftpd/Makefile')
-rw-r--r--ftp/proftpd/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index a57676ce9957..ce72f9182cbf 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -85,7 +85,8 @@ OPTIONS= IPV6 "Use IPv6" off \
CYRFIX "Patch to fix cyrillic encoding" off \
CLAMAV "Include mod_clamav" off \
DIGEST "Include mod_digest" off \
- COMB "Include mod_comb (multistream upload)" off
+ COMB "Include mod_comb (multistream upload)" off \
+ CODECONV "Use charset conversion (mod_codeconv)" off
MODULES?=
LIBDIRS?=
@@ -258,6 +259,15 @@ LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds
.endif
+.if defined(WITH_CODECONV)
+USE_ICONV= YES
+MODULES:=${MODULES}:mod_codeconv
+INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
+CONFIGURE_ARGS+= --disable-sendfile
+PROFTPD_LIBS+= -liconv -L${LOCALBASE}/lib
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mod-codeconv
+.endif
+
# mod_ifsession should be the last item in the modules list
.if !defined(WITHOUT_IFSESSION)
MODULES:=${MODULES}:mod_ifsession