aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd/files
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2003-11-04 03:40:38 +0800
committermharo <mharo@FreeBSD.org>2003-11-04 03:40:38 +0800
commitd3cbe810beff14f4e92c6cd80047bc5ad65e5e9a (patch)
treed0009f0af1b8a537c4e043ccda6162ae7de9382b /ftp/proftpd/files
parent0727f97c24c4993e83e487c13f246117883a9d56 (diff)
downloadfreebsd-ports-gnome-d3cbe810beff14f4e92c6cd80047bc5ad65e5e9a.tar.gz
freebsd-ports-gnome-d3cbe810beff14f4e92c6cd80047bc5ad65e5e9a.tar.zst
freebsd-ports-gnome-d3cbe810beff14f4e92c6cd80047bc5ad65e5e9a.zip
58774 Andrew J. Caines <A.J.Caines@halplant.com>
upgrade to 1.2.9 58415 Melvyn Sopacua <mdev@idg.nl> add WITH_OPENSSL 57385 Martin Matuska <martin@tradex.sk> adds rc_subr support 54783 Bruce M Simpson <bms@spc.org> Ability to support multiple versions MYSQL and LDAP using the WITH_* variables. I ended up using the stuff provided in bsd.port.mk with his patches
Diffstat (limited to 'ftp/proftpd/files')
-rw-r--r--ftp/proftpd/files/patch-ah6
-rw-r--r--ftp/proftpd/files/patch-configure13
-rw-r--r--ftp/proftpd/files/patch-contrib::mod_sql_mysql.c11
-rw-r--r--ftp/proftpd/files/patch-pgsql11
-rw-r--r--ftp/proftpd/files/proftpd.sh41
-rw-r--r--ftp/proftpd/files/proftpd.sh.sample19
6 files changed, 61 insertions, 40 deletions
diff --git a/ftp/proftpd/files/patch-ah b/ftp/proftpd/files/patch-ah
index b859648d8cf3..2b9dc49f0b01 100644
--- a/ftp/proftpd/files/patch-ah
+++ b/ftp/proftpd/files/patch-ah
@@ -1,10 +1,10 @@
--- modules/mod_auth_unix.c.orig Thu Mar 13 14:00:00 2003
+++ modules/mod_auth_unix.c Thu Mar 13 14:04:45 2003
-@@ -58,6 +58,7 @@
+@@ -57,6 +57,7 @@
#endif /* HAVE_HPSECURITY_H or HPUX10 or HPUX11 */
#if defined(HAVE_PROT_H) || defined(COMSEC)
-+#include <krb.h>
- #include <prot.h>
++# include <krb.h>
+ # include <prot.h>
#endif
diff --git a/ftp/proftpd/files/patch-configure b/ftp/proftpd/files/patch-configure
index cac88f2bf706..1f7399541f8d 100644
--- a/ftp/proftpd/files/patch-configure
+++ b/ftp/proftpd/files/patch-configure
@@ -1,12 +1,11 @@
--- ./configure.orig Fri Mar 14 18:19:10 2003
+++ ./configure Fri Mar 14 18:19:25 2003
@@ -11202,8 +11202,8 @@
- #if HAVE_NETDB_H
- #include <netdb.h>
- #endif
--#include <sys/socket.h>
- #include <sys/types.h>
-+#include <sys/socket.h>
+ #if HAVE_NETDB_H
+ #include <netdb.h>
+ #endif
+- #include <sys/socket.h>
+ #include <sys/types.h>
++ #include <sys/socket.h>
int
- main ()
diff --git a/ftp/proftpd/files/patch-contrib::mod_sql_mysql.c b/ftp/proftpd/files/patch-contrib::mod_sql_mysql.c
new file mode 100644
index 000000000000..9da89767a223
--- /dev/null
+++ b/ftp/proftpd/files/patch-contrib::mod_sql_mysql.c
@@ -0,0 +1,11 @@
+--- contrib/mod_sql_mysql.c.orig Sun Nov 2 00:30:13 2003
++++ contrib/mod_sql_mysql.c Sun Nov 2 00:30:23 2003
+@@ -134,7 +134,7 @@
+
+ #define _MYSQL_PORT "3306"
+
+-#include <mysql.h>
++#include <mysql/mysql.h>
+ #include "conf.h"
+ #include "../contrib/mod_sql.h"
+
diff --git a/ftp/proftpd/files/patch-pgsql b/ftp/proftpd/files/patch-pgsql
deleted file mode 100644
index 9c169e79c8f6..000000000000
--- a/ftp/proftpd/files/patch-pgsql
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./contrib/mod_sql_postgres.c.orig Sun Oct 6 21:47:43 2002
-+++ ./contrib/mod_sql_postgres.c Sun Oct 6 21:47:50 2002
-@@ -35,7 +35,7 @@
-
- #define _POSTGRES_PORT "5432"
-
--#include <pgsql/libpq-fe.h>
-+#include <libpq-fe.h>
- #include "conf.h"
- #include "../contrib/mod_sql.h"
-
diff --git a/ftp/proftpd/files/proftpd.sh b/ftp/proftpd/files/proftpd.sh
new file mode 100644
index 000000000000..244e80cb9346
--- /dev/null
+++ b/ftp/proftpd/files/proftpd.sh
@@ -0,0 +1,41 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: proftpd
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable proftpd:
+#
+#proftpd_enable="YES"
+#
+# See proftpd(8) for flags
+#
+
+. %%RC_SUBR%%
+
+name=proftpd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/libexec/proftpd
+pidfile=/var/run/proftpd.pid
+required_files=%%PREFIX%%/etc/proftpd.conf
+
+stop_postcmd=stop_postcmd
+
+stop_postcmd()
+{
+ rm -f $pidfile
+}
+
+# set defaults
+
+proftpd_enable=${proftpd_enable:-"NO"}
+proftpd_flags=${proftpd_flags:-""}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/ftp/proftpd/files/proftpd.sh.sample b/ftp/proftpd/files/proftpd.sh.sample
deleted file mode 100644
index ad976fa3984f..000000000000
--- a/ftp/proftpd/files/proftpd.sh.sample
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-
-case "$1" in
-
-start)
- /bin/mkdir -p /var/run/proftpd
- if [ -x /usr/local/libexec/proftpd ]; then
- /usr/local/libexec/proftpd && echo -n ' proftpd'
- fi
- ;;
-
-stop)
- killall proftpd
- ;;
-*)
- echo "$0 start | stop"
- ;;
-
-esac