aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2004-08-29 02:10:38 +0800
committermharo <mharo@FreeBSD.org>2004-08-29 02:10:38 +0800
commit2e7552c42e298f937384bec7f95d99fd592a932e (patch)
treed01fea595fb2946aac3a13f83b1c24e461038080 /ftp/proftpd
parent07fb9f1b51e75ea2c5a3c52b8f9ccb62b76b56ef (diff)
downloadfreebsd-ports-gnome-2e7552c42e298f937384bec7f95d99fd592a932e.tar.gz
freebsd-ports-gnome-2e7552c42e298f937384bec7f95d99fd592a932e.tar.zst
freebsd-ports-gnome-2e7552c42e298f937384bec7f95d99fd592a932e.zip
add option to compile with support for quotas
PR: 68644 Submitted by: Krzysztof Stryjek <wtp+proftpd@bsdguru.org>
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index e55176081cee..cab6afab60bd 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -113,6 +113,16 @@ MAN8+= ftpdctl.8
.else
.endif
+.if defined(WITH_QUOTA)
+MODULES:=${MODULES}:mod_quotatab:mod_quotatab_file
+.if defined(WITH_LDAP)
+MODULES:=${MODULES}:mod_quotatab_ldap
+.endif
+.if defined(WITH_POSTGRESQL) || defined(WITH_MYSQL)
+MODULES:=${MODULES}:mod_quotatab_sql
+.endif
+.endif
+
# Keep this here below, in case similar constructs need to be made
CONFIGURE_ENV+= "LIBS=${PROFTPD_LIBS}"