aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2007-09-18 08:10:25 +0800
committerbeech <beech@FreeBSD.org>2007-09-18 08:10:25 +0800
commit79aa266e60c5459342b808a1d37cbbabc40bd12e (patch)
treeba817017b5629ed14240f7e28711d07adb1202d8 /ftp/proftpd
parent5a50cf1d48269c6b94b7ba588fce4dba7df04df3 (diff)
downloadfreebsd-ports-gnome-79aa266e60c5459342b808a1d37cbbabc40bd12e.tar.gz
freebsd-ports-gnome-79aa266e60c5459342b808a1d37cbbabc40bd12e.tar.zst
freebsd-ports-gnome-79aa266e60c5459342b808a1d37cbbabc40bd12e.zip
- Add patch to fix build.
Approved by: sat (maintainer) Obtained from: TJ Saunders <tj@castaglia.org> (developer)
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile2
-rw-r--r--ftp/proftpd/files/patch-modules-Makefile.in25
2 files changed, 26 insertions, 1 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 89c196d926a0..f76c3dd241c3 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -216,7 +216,7 @@ MODULES:=${MODULES}:mod_quotatab_sql
DISTFILES+= mod_clamav-0.5.tar.bz2:clam
USE_CLAMAV= yes
MODULES:=${MODULES}:mod_clamav
-LIB_DEPENDS+= clamav.2:${PORTSDIR}/security/clamav
+LIB_DEPENDS+= clamav.2:${PORTSDIR}/security/clamav
INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
.endif
diff --git a/ftp/proftpd/files/patch-modules-Makefile.in b/ftp/proftpd/files/patch-modules-Makefile.in
new file mode 100644
index 000000000000..7bf4e642ed27
--- /dev/null
+++ b/ftp/proftpd/files/patch-modules-Makefile.in
@@ -0,0 +1,25 @@
+Index: modules/Makefile.in
+===================================================================
+RCS file: /cvsroot/proftp/proftpd/modules/Makefile.in,v
+retrieving revision 1.24
+diff -u -r1.24 Makefile.in
+--- modules/Makefile.in 8 Jan 2007 19:58:22 -0000 1.24
++++ modules/Makefile.in 17 Sep 2007 17:27:11 -0000
+@@ -50,7 +50,7 @@
+ test -z "$(SHARED_MODULE_OBJS)" || $(LIBTOOL) --mode=install $(INSTALL_BIN) $(SHARED_MODULE_OBJS) $(DESTDIR)$(LIBEXECDIR)
+ @dirs="$(SHARED_MODULE_DIRS)"; \
+ for dir in $$dirs; do\
+- cd $(top_srcdir)/$$dir/ && $(MAKE) install; \
++ (cd $(top_srcdir)/$$dir/ && $(MAKE) install); \
+ done
+
+ clean:
+@@ -59,7 +59,7 @@
+ $(LIBTOOL) --mode=clean $(RM) `echo $(SHARED_MODULE_OBJS) | sed 's/\.la$\/.lo/g'`
+ @dirs="$(SHARED_MODULE_DIRS) $(STATIC_MODULE_DIRS)"; \
+ for dir in $$dirs; do\
+- cd $(top_srcdir)/$$dir/ && $(MAKE) clean; \
++ (cd $(top_srcdir)/$$dir/ && $(MAKE) clean); \
+ done
+
+ depend: