aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2007-11-15 05:00:58 +0800
committerbeech <beech@FreeBSD.org>2007-11-15 05:00:58 +0800
commit9d0c5cd73f3788eb8e413f0a96908e461d034f3f (patch)
tree67fa43d05787029785bca06e141b92ab6b05b2fd /ftp/proftpd
parent9beb18a05bcbb73af797ca3ea6fa02f5101ef26c (diff)
downloadfreebsd-ports-gnome-9d0c5cd73f3788eb8e413f0a96908e461d034f3f.tar.gz
freebsd-ports-gnome-9d0c5cd73f3788eb8e413f0a96908e461d034f3f.tar.zst
freebsd-ports-gnome-9d0c5cd73f3788eb8e413f0a96908e461d034f3f.zip
- Fix connect stops with Sig11 on FreeBSD AMD64
- Remove option --enable-builtin-getnameinfo - Add README docs - Bump portrevision Submitted by: http://bugs.proftpd.org/show_bug.cgi?id=3000 Approved by: portmgr (linimon, mentor)
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index e3ab3a76a711..636414396699 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -30,7 +30,10 @@ PORTDOCSdoc= Configuration.html faq.html
PORTDOCScontrib=mod_ifsession.html mod_radius.html mod_rewrite.html \
mod_tls.html mod_wrap2.html mod_wrap2_file.html mod_wrap2_sql.html \
mod_ban.html mod_quotatab_radius.html ftpasswd.html
-PORTDOCS= ${PORTDOCSdoc} ${PORTDOCScontrib}
+PORTDOCSreadme= README README.DSO README.FreeBSD README.IPv6 README.LDAP README.PAM \
+ README.capabilities README.classes README.facl README.modules \
+ README.ports RELEASE_NOTES
+PORTDOCS= ${PORTDOCSdoc} ${PORTDOCScontrib} ${PORTDOCSreadme}
PORTEXAMPLES= ASCII.html CreateHome.html Filters.html SQL.html Umask.html \
AuthFiles.html DNS.html Globbing.html SSH.html Upgrade.html \
@@ -50,7 +53,6 @@ USE_RC_SUBR= proftpd.sh
CONFIGURE_ARGS= --localstatedir=/var/run \
--sysconfdir=${PREFIX}/etc \
- --enable-builtin-getnameinfo \
--disable-sendfile
OPTIONS= IPV6 "Use IPv6" off \
@@ -273,6 +275,7 @@ post-install:
@${INSTALL} -d ${DOCSDIR}/
@cd ${WRKSRC}/doc/ && ${INSTALL_DATA} ${PORTDOCSdoc} ${DOCSDIR}/
@cd ${WRKSRC}/doc/contrib && ${INSTALL_DATA} ${PORTDOCScontrib} ${DOCSDIR}/
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCSreadme} ${DOCSDIR}/
.endif
.if !defined(NOPORTEXAMPLES)
@${INSTALL} -d ${EXAMPLESDIR}/