aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/pure-ftpd/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-03-09 03:38:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-03-09 03:38:18 +0800
commitb9d93dcd4fb1df5e8834c6ad7f77de9a65765d2d (patch)
treecfb9aa58032297481a21d0b67307ced9ba609c5c /ftp/pure-ftpd/Makefile
parent91c4b2a34386cbaba52bde155e9e483f18c60bce (diff)
downloadfreebsd-ports-gnome-b9d93dcd4fb1df5e8834c6ad7f77de9a65765d2d.tar.gz
freebsd-ports-gnome-b9d93dcd4fb1df5e8834c6ad7f77de9a65765d2d.tar.zst
freebsd-ports-gnome-b9d93dcd4fb1df5e8834c6ad7f77de9a65765d2d.zip
- Enable TLS option by default
- Allow to change location of pid files - Bump PORTREVISION for package change
Diffstat (limited to 'ftp/pure-ftpd/Makefile')
-rw-r--r--ftp/pure-ftpd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index e581d276dbe2..1734eef6d31b 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pure-ftpd
PORTVERSION= 1.0.36
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp ipv6
MASTER_SITES= http://download.pureftpd.org/pub/pure-ftpd/releases/ \
ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/ \
@@ -17,7 +17,7 @@ LICENSE= ISCL
OPTIONS_DEFINE= ANONDELETE ANONRENAME ANONRESUME DOCS EXAMPLES LARGEFILE LDAP \
MYSQL PAM PERUSERLIMITS PGSQL PRIVSEP SENDFILE THROTTLING TLS \
UPLOADSCRIPT UTF8 VIRTUALCHROOT
-OPTIONS_DEFAULT=PAM PRIVSEP SENDFILE VIRTUALCHROOT
+OPTIONS_DEFAULT=PAM PRIVSEP SENDFILE TLS VIRTUALCHROOT
ANONDELETE_DESC= Allow anonymous user to delete files
ANONRENAME_DESC= Allow anonymous user to rename files
ANONRESUME_DESC= Allow anonymous user to resume file upload
@@ -75,8 +75,8 @@ PGSQL_USES= pgsql
PRIVSEP_CONFIGURE_WITH= privsep
SENDFILE_CONFIGURE_WITH=sendfile
THROTTLING_CONFIGURE_WITH= throttling
-TLS_CONFIGURE_ON= --with-certfile=${TLS_CERTFILE}
-TLS_CONFIGURE_WITH= tls
+TLS_CONFIGURE_OFF= --without-tls
+TLS_CONFIGURE_ON= --with-certfile=${TLS_CERTFILE} --with-tls
UPLOADSCRIPT_CONFIGURE_WITH= uploadscript
UTF8_CONFIGURE_WITH= rfc2640
UTF8_USES= iconv