aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/pure-ftpd/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-07-15 16:33:04 +0800
committerroam <roam@FreeBSD.org>2001-07-15 16:33:04 +0800
commit316e715e0243eb6556b8481ed05b50613913e5e2 (patch)
treed5ada64a256032f5090b420a5728f7e082cea2d9 /ftp/pure-ftpd/Makefile
parent3c5e5ff71b26161e9900ac6f0f910839185c9a3d (diff)
downloadfreebsd-ports-gnome-316e715e0243eb6556b8481ed05b50613913e5e2.tar.gz
freebsd-ports-gnome-316e715e0243eb6556b8481ed05b50613913e5e2.tar.zst
freebsd-ports-gnome-316e715e0243eb6556b8481ed05b50613913e5e2.zip
Update to 0.98.7.
Add sample PAM configuration files. PR: 28275 Submitted by: maintainer
Diffstat (limited to 'ftp/pure-ftpd/Makefile')
-rw-r--r--ftp/pure-ftpd/Makefile24
1 files changed, 22 insertions, 2 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index 497a6987be4c..837c8c696145 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pure-ftpd
-PORTVERSION= 0.98.6
+PORTVERSION= 0.98.7
CATEGORIES= ftp ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pureftpd
@@ -33,6 +33,20 @@ CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
MAN8= pure-ftpd.8 pure-ftpwho.8 pure-mrtginfo.8 pure-uploadscript.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+PAM_TEMPL?= ${FILESDIR}/pam.conf.5
+.else
+. if ${OSVERSION} > 400000
+PAM_TEMPL?= ${FILESDIR}/pam.conf.4
+. endif
+.endif
+.if defined(PAM_TEMPL)
+PAM_DIR?= ${PREFIX}/share/examples/${PORTNAME}/pam
+PAM_TARGET?= pure-ftpd
+.endif
+
DOCS= AUTHORS CONTACT COPYING HISTORY NEWS \
README README.Configuration-File README.Contrib README.LDAP \
README.Netfilter \
@@ -57,5 +71,11 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/pure-ftpd
(cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${PREFIX}/share/doc/pure-ftpd)
.endif
+.if defined(PAM_TEMPL)
+ ${MKDIR} ${PAM_DIR}
+ ${INSTALL_DATA} ${PAM_TEMPL} ${PAM_DIR}/${PAM_TARGET}
+ @${ECHO} "Now you need to examine ${PAM_DIR}/${PAM_TARGET}"
+ @${ECHO} "and add the relevant PAM configuration lines to your /etc/pam.conf file."
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>