aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/pure-ftpd/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-06-14 02:26:53 +0800
committerroam <roam@FreeBSD.org>2001-06-14 02:26:53 +0800
commit8c89de6c828b543a462d2ea1a465aec996d9d77d (patch)
treee3aab7a2e6acfacbf7c6e8aee37c1e9becb8a4d3 /ftp/pure-ftpd/Makefile
parenta90be839bff45ee47fb340e5ae6e8a2e49f7f4fd (diff)
downloadfreebsd-ports-gnome-8c89de6c828b543a462d2ea1a465aec996d9d77d.tar.gz
freebsd-ports-gnome-8c89de6c828b543a462d2ea1a465aec996d9d77d.tar.zst
freebsd-ports-gnome-8c89de6c828b543a462d2ea1a465aec996d9d77d.zip
Update to 0.98.5. Also, install the contents of the contrib/ directory
under share/examples. PR: 28118 Submitted by: maintainer
Diffstat (limited to 'ftp/pure-ftpd/Makefile')
-rw-r--r--ftp/pure-ftpd/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index f5feb39414c4..4e7a0002a919 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pure-ftpd
-PORTVERSION= 0.98.4
+PORTVERSION= 0.98.5
CATEGORIES= ftp ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pureftpd
@@ -20,7 +20,7 @@ LIB_DEPENDS+= dmalloc.1:${PORTSDIR}/devel/dmalloc
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-pam --with-cookie --with-throttling \
--with-ratios --with-ftpwho --with-largefile \
- --with-uploadscript
+ --with-uploadscript --with-virtualhosts
# language support requested?
.if defined(WITH_LANG)
CONFIGURE_ARGS+= --with-language="${WITH_LANG}"
@@ -34,9 +34,12 @@ CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
MAN8= pure-ftpd.8 pure-ftpwho.8 pure-mrtginfo.8 pure-uploadscript.8
DOCS= AUTHORS CONTACT COPYING HISTORY NEWS \
- README README.Configuration-File README.LDAP README.Netfilter \
+ README README.Configuration-File README.Contrib README.LDAP \
+ README.Netfilter \
THANKS
+CONTRIB= xml_python_processors.txt
+
pre-fetch:
@${ECHO} "You can use the following additional options:"
@${ECHO} "WITH_DMALLOC - enable use of the dmalloc library;"
@@ -47,6 +50,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/pureftpd-ldap.conf ${PREFIX}/etc/pureftpd-ldap.conf.sample
${INSTALL_DATA} ${WRKSRC}/configuration-file/pure-ftpd.conf ${PREFIX}/etc/pure-ftpd.conf.sample
${INSTALL_DATA} ${WRKSRC}/configuration-file/pure-config.pl ${PREFIX}/sbin/
+ ${MKDIR} ${PREFIX}/share/examples/pure-ftpd
+ (cd ${WRKSRC}/contrib && ${INSTALL_SCRIPT} ${CONTRIB} ${PREFIX}/share/examples/pure-ftpd)
${CHMOD} 755 ${PREFIX}/sbin/pure-config.pl
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/pure-ftpd