aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/py-pyftpdlib
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-04 02:18:02 +0800
committeradamw <adamw@FreeBSD.org>2014-07-04 02:18:02 +0800
commitc26fe43e8a72cff2575818dc5b7dd0bc3e7f9649 (patch)
treeb536625912e0dbf4d80e3e4ce6844a97d066e3da /ftp/py-pyftpdlib
parent2af463a232ffc193db01e274d26c03a57826513b (diff)
downloadfreebsd-ports-gnome-c26fe43e8a72cff2575818dc5b7dd0bc3e7f9649.tar.gz
freebsd-ports-gnome-c26fe43e8a72cff2575818dc5b7dd0bc3e7f9649.tar.zst
freebsd-ports-gnome-c26fe43e8a72cff2575818dc5b7dd0bc3e7f9649.zip
Resolve unnecessary bsd.port.options.mk inclusion by using OPTIONS helpers.
Approved by: portmgr (blanket)
Diffstat (limited to 'ftp/py-pyftpdlib')
-rw-r--r--ftp/py-pyftpdlib/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/ftp/py-pyftpdlib/Makefile b/ftp/py-pyftpdlib/Makefile
index 01cf33ce4199..5780a11e38ed 100644
--- a/ftp/py-pyftpdlib/Makefile
+++ b/ftp/py-pyftpdlib/Makefile
@@ -16,7 +16,7 @@ LICENSE= MIT
USE_PYTHON= 2
USE_PYDISTUTILS= yes
-OPTIONS_DEFINE= SENDFILE OPENSSL
+OPTIONS_DEFINE= SENDFILE OPENSSL EXAMPLES
OPTIONS_DEFAULT= SENDFILE OPENSSL
SENDFILE_DESC= Enable sendfile(2) support
OPENSSL_DESC= Enable FTP over SSL/TLS (RFC4217)
@@ -24,23 +24,14 @@ OPENSSL_DESC= Enable FTP over SSL/TLS (RFC4217)
# Workaround ports infrastructure bug
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSENDFILE}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pysendfile>0:${PORTSDIR}/net/py-pysendfile
-.endif
-
-.if ${PORT_OPTIONS:MOPENSSL}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}openssl>0:${PORTSDIR}/security/py-openssl
-.endif
+SENDFILE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pysendfile>0:${PORTSDIR}/net/py-pysendfile
+OPENSSL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>0:${PORTSDIR}/security/py-openssl
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-install:
-.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKSRC}/demo/ ${STAGEDIR}${EXAMPLESDIR}
-.endif
test: build
${TOUCH} ${WRKSRC}/test/__init__.py