aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/quftp
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2004-12-05 19:27:30 +0800
committerkwm <kwm@FreeBSD.org>2004-12-05 19:27:30 +0800
commit0dfcadf3d48e157eb5318e59d09cb369d68ca6ec (patch)
tree76b504c24d5f21cfde9f441a9992613d6f3e5a87 /ftp/quftp
parentdb25d9553b52557bdb602d474c9d8c5ccc91cb0c (diff)
downloadfreebsd-ports-gnome-0dfcadf3d48e157eb5318e59d09cb369d68ca6ec.tar.gz
freebsd-ports-gnome-0dfcadf3d48e157eb5318e59d09cb369d68ca6ec.tar.zst
freebsd-ports-gnome-0dfcadf3d48e157eb5318e59d09cb369d68ca6ec.zip
Fix build on sparc64.
PR: 73979 Submitted by: maintainer
Diffstat (limited to 'ftp/quftp')
-rw-r--r--ftp/quftp/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/ftp/quftp/Makefile b/ftp/quftp/Makefile
index b3745ef8ab76..600947491ccb 100644
--- a/ftp/quftp/Makefile
+++ b/ftp/quftp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quftp
PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= quftp
@@ -18,6 +18,7 @@ COMMENT= A scriptable FTP client
LIB_DEPENDS= readline.5:${PORTSDIR}/devel/readline
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CFLAGS+= ${PTHREAD_CFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
@@ -26,4 +27,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= quftp.1
PLIST_FILES= bin/quftp
+pre-configure:
+ @${REINPLACE_CMD} -e 's|-O6|-O2|g' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>