aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/sftp/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-12-31 10:27:05 +0800
committersteve <steve@FreeBSD.org>1999-12-31 10:27:05 +0800
commit70dc560a2f78a78aac4ab4785c141092c74db3a5 (patch)
treef736aaef6f66814a1afa46ca9ab9acbf483dceff /ftp/sftp/Makefile
parenta20a1ff7dae39040dd227aa2045b11ffe958a5f7 (diff)
downloadfreebsd-ports-gnome-70dc560a2f78a78aac4ab4785c141092c74db3a5.tar.gz
freebsd-ports-gnome-70dc560a2f78a78aac4ab4785c141092c74db3a5.tar.zst
freebsd-ports-gnome-70dc560a2f78a78aac4ab4785c141092c74db3a5.zip
Adding sftp version 0.5.
An ftp(1) replacement that runs over an ssh tunnel. PR: 15777 Submitted by: Cy Shubert <Cy.Shubert@uumail.gov.bc.ca>
Diffstat (limited to 'ftp/sftp/Makefile')
-rw-r--r--ftp/sftp/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/ftp/sftp/Makefile b/ftp/sftp/Makefile
new file mode 100644
index 000000000000..50751402111d
--- /dev/null
+++ b/ftp/sftp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: sftp
+# Version required: 0.5
+# Date created: 30 December 1999
+# Whom: Cy Shubert <Cy.Shubert@uumail.gov.bc.ca>
+#
+# $FreeBSD$
+#
+
+DISTNAME= sftp-0.5
+CATEGORIES= ftp security
+MASTER_SITES= ftp://ftp.xbill.org/pub/sftp/
+
+MAINTAINER= Cy.Schubert@uumail.gov.bc.ca
+
+RUN_DEPENDS= ssh:${PORTSDIR}/security/openssh
+
+RESTRICTED= "Calls external cryptographic routines."
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --enable-remotepath=${PREFIX}/libexec
+
+MAN1= sftp.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sftp ${PREFIX}/bin/sftp
+ ${LN} -s ${PREFIX}/bin/sftp ${PREFIX}/bin/rsftp
+ ${INSTALL_PROGRAM} ${WRKSRC}/sftpserv ${PREFIX}/libexec/sftpserv
+ ${INSTALL_MAN} ${WRKSRC}/sftp.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>