aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/smbftpd/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2010-11-09 20:33:00 +0800
committersunpoet <sunpoet@FreeBSD.org>2010-11-09 20:33:00 +0800
commit03edea38a6c3636286d7a83805e8ec3ac86743b1 (patch)
treed3d2d7ad612bcc917d37f8a9b9e30f5d56f7c62e /ftp/smbftpd/Makefile
parentd5e5504b6b47145a6833ea7cf4faf93fc9682151 (diff)
downloadfreebsd-ports-gnome-03edea38a6c3636286d7a83805e8ec3ac86743b1.tar.gz
freebsd-ports-gnome-03edea38a6c3636286d7a83805e8ec3ac86743b1.tar.zst
freebsd-ports-gnome-03edea38a6c3636286d7a83805e8ec3ac86743b1.zip
- Install configuration files as *.sample to avoid overriding existing ones
- Use ETCDIR - Bump PORTEVISION PR: ports/150145 Submitted by: Sergey Zaykov <mail_of_sergey@mail.ru> (based on) Approved by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw> (maintainer)
Diffstat (limited to 'ftp/smbftpd/Makefile')
-rw-r--r--ftp/smbftpd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/ftp/smbftpd/Makefile b/ftp/smbftpd/Makefile
index ff3ebac39c21..103a9ddad549 100644
--- a/ftp/smbftpd/Makefile
+++ b/ftp/smbftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smbftpd
PORTVERSION= 2.2
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= SF/${PORTNAME}/SmbFTPD/${PORTVERSION} \
http://www.twbsd.org/download/download.php?file=smbftpd/
@@ -24,7 +25,7 @@ MAKE_ENV= OSTYPE=FreeBSD
CONFIGURE_ARGS= "--prefix=${PREFIX}"
USE_PERL5= yes
-USE_RC_SUBR= smbftpd.sh
+USE_RC_SUBR= ${PORTNAME}.sh
.include <bsd.port.pre.mk>
@@ -51,4 +52,8 @@ CONFIGURE_ARGS+= "--with-ssl"
BROKEN= fails to build with new utmpx
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/^CONFIGS = / s|\.conf|&.sample|g' ${WRKSRC}/Makefile
+ @cd ${WRKSRC}/conf/ && (${LS} *.conf | ${XARGS} -I % ${MV} % %.sample)
+
.include <bsd.port.post.mk>