aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/smbftpd/Makefile
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-08-15 09:04:30 +0800
committerdougb <dougb@FreeBSD.org>2012-08-15 09:04:30 +0800
commit320cd1ea2d17c86179fa69a8da5584397ab2a2e1 (patch)
treeb03e7cfe150ed1b6857b68211969a31d1b599c54 /ftp/smbftpd/Makefile
parent5a2fb644bcdcc0667463dfc374adb0058abbdd9d (diff)
downloadfreebsd-ports-gnome-320cd1ea2d17c86179fa69a8da5584397ab2a2e1.tar.gz
freebsd-ports-gnome-320cd1ea2d17c86179fa69a8da5584397ab2a2e1.tar.zst
freebsd-ports-gnome-320cd1ea2d17c86179fa69a8da5584397ab2a2e1.zip
Fix problem introduced in r302141. The directory for the unpacked source
files is unversioned, so it conflicts with the name of the rc.d script in WRKDIR after SUB_FILES is applied.
Diffstat (limited to 'ftp/smbftpd/Makefile')
-rw-r--r--ftp/smbftpd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ftp/smbftpd/Makefile b/ftp/smbftpd/Makefile
index 15b69b119f1c..b3d42f845b35 100644
--- a/ftp/smbftpd/Makefile
+++ b/ftp/smbftpd/Makefile
@@ -24,7 +24,6 @@ HAS_CONFIGURE= yes
MAKE_ENV= OSTYPE=FreeBSD
CONFIGURE_ARGS= "--prefix=${PREFIX}"
-WRKSRC= ${WRKDIR}/${PORTNAME}
USE_PERL5= yes
USE_RC_SUBR= ${PORTNAME}
@@ -49,6 +48,9 @@ CONFIGURE_ARGS+= "--with-iconv"
CONFIGURE_ARGS+= "--with-ssl"
.endif
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
post-patch:
@${REINPLACE_CMD} -e '/^CONFIGS = / s|\.conf|&.sample|g' ${WRKSRC}/Makefile
@cd ${WRKSRC}/conf/ && (${LS} *.conf | ${XARGS} -I % ${MV} % %.sample)