aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/smbftpd/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-06-25 10:52:33 +0800
committerbeech <beech@FreeBSD.org>2008-06-25 10:52:33 +0800
commitbbc562caf97a60daaf83446a1453dd235c6a0f22 (patch)
tree3aab4b76f9ea684733d069745f995354a9037f12 /ftp/smbftpd/Makefile
parent664c415d42cd1db20b411134f782cf0514c69724 (diff)
downloadfreebsd-ports-gnome-bbc562caf97a60daaf83446a1453dd235c6a0f22.tar.gz
freebsd-ports-gnome-bbc562caf97a60daaf83446a1453dd235c6a0f22.tar.zst
freebsd-ports-gnome-bbc562caf97a60daaf83446a1453dd235c6a0f22.zip
- Update to 2.0
Added file(s): - files/patch-Makefile - files/smbftpd.sh.in PR: ports/124363 Submitted by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw> (maintainer)
Diffstat (limited to 'ftp/smbftpd/Makefile')
-rw-r--r--ftp/smbftpd/Makefile39
1 files changed, 34 insertions, 5 deletions
diff --git a/ftp/smbftpd/Makefile b/ftp/smbftpd/Makefile
index 6021b55a15ad..8fc654ab12a9 100644
--- a/ftp/smbftpd/Makefile
+++ b/ftp/smbftpd/Makefile
@@ -6,17 +6,46 @@
#
PORTNAME= smbftpd
-PORTVERSION= 0.97
+PORTVERSION= 2.0
CATEGORIES= ftp
-MASTER_SITES= http://www.twbsd.org/download/download.php?file=smbftpd/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.twbsd.org/download/download.php?file=smbftpd/
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= FTP daemon using Samba-like share management mechanism
+OPTIONS= MYSQL "Users database is a MySQL database" off \
+ PGSQL "Users database is a PostgreSQL database" off \
+ SSL "Enable SSL/TLS support" off \
+ ICONV "Enable codepage to unicode conversion for UTF-8 FTP" off
+
HAS_CONFIGURE= yes
-USE_OPENSSL= yes
+MAKE_ENV= OSTYPE=FreeBSD
+CONFIGURE_ARGS= "--prefix=${PREFIX}"
+
+.include <bsd.port.pre.mk>
+
USE_PERL5= yes
+USE_RC_SUBR= smbftpd.sh
-MAKE_ENV= OSTYPE=FreeBSD
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= "--with-mysql"
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+CONFIGURE_ARGS+= "--with-pgsql"
+.endif
+
+.if defined(WITH_ICONV)
+USE_ICONV= yes
+CONFIGURE_ARGS+= "--with-iconv"
+.endif
+
+.if defined(WITH_SSL)
+CONFIGURE_ARGS+= "--with-ssl"
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>