aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/spegla
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1998-04-20 09:57:34 +0800
committerjkh <jkh@FreeBSD.org>1998-04-20 09:57:34 +0800
commit205ce9b3ca7b9b35ec686108e64c513871d3d739 (patch)
treee9a7cb142bc9156ac22ab18bf7cf8acd05a68d31 /ftp/spegla
parent6c4ce040552ed80844a01c148779eaa9b755443e (diff)
downloadfreebsd-ports-gnome-205ce9b3ca7b9b35ec686108e64c513871d3d739.tar.gz
freebsd-ports-gnome-205ce9b3ca7b9b35ec686108e64c513871d3d739.tar.zst
freebsd-ports-gnome-205ce9b3ca7b9b35ec686108e64c513871d3d739.zip
This has been on my TODO list for awhile. Spegla is an FTP mirroring
program that uses neither perl nor masses of memory when mirroring large collections (like at ftp.freebsd.org). I did the port but the author is Jens A Nilsson <jnilsson@ludd.luth.se>
Diffstat (limited to 'ftp/spegla')
-rw-r--r--ftp/spegla/Makefile22
-rw-r--r--ftp/spegla/distinfo1
-rw-r--r--ftp/spegla/files/patch-aa9
-rw-r--r--ftp/spegla/pkg-comment1
-rw-r--r--ftp/spegla/pkg-descr52
-rw-r--r--ftp/spegla/pkg-plist3
6 files changed, 88 insertions, 0 deletions
diff --git a/ftp/spegla/Makefile b/ftp/spegla/Makefile
new file mode 100644
index 000000000000..dc46461ffc86
--- /dev/null
+++ b/ftp/spegla/Makefile
@@ -0,0 +1,22 @@
+# ex:ts=8
+# New ports collection makefile for: spegla
+# Version required: 0.93p2
+# Date created: Sun Apr 19 16:17:25 PDT 1998
+# Whom: Jordan Hubbard <jkh@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= spegla-0.93p2
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.luth.se/pub/unix/mirror/
+
+MAINTAINER= jkh@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/spegla
+
+post-install:
+ @mkdir -p ${PREFIX}/share/examples/spegla
+ ${INSTALL} -c -m 444 ${WRKSRC}/freebsd.org ${PREFIX}/share/examples/spegla
+
+.include <bsd.port.mk>
diff --git a/ftp/spegla/distinfo b/ftp/spegla/distinfo
new file mode 100644
index 000000000000..cf50629e9a3d
--- /dev/null
+++ b/ftp/spegla/distinfo
@@ -0,0 +1 @@
+MD5 (spegla-0.93p2.tar.gz) = 04851f281e5754af8402940916e3f51d
diff --git a/ftp/spegla/files/patch-aa b/ftp/spegla/files/patch-aa
new file mode 100644
index 000000000000..bf1322f2cf3d
--- /dev/null
+++ b/ftp/spegla/files/patch-aa
@@ -0,0 +1,9 @@
+--- Makefile.orig Sun Apr 19 18:39:02 1998
++++ Makefile Sun Apr 19 18:42:04 1998
+@@ -1,4 +1,6 @@
+ # $Id: Makefile,v 1.6 1998/01/19 22:59:51 jens Exp $
++BINDIR= ${PREFIX}/bin
++
+ PROG= spegla
+ SRCS= jftp.c parserow.c spegla.c readconfig.c
+
diff --git a/ftp/spegla/pkg-comment b/ftp/spegla/pkg-comment
new file mode 100644
index 000000000000..33643a63db4e
--- /dev/null
+++ b/ftp/spegla/pkg-comment
@@ -0,0 +1 @@
+A mirror program for FTP sites (written in C)
diff --git a/ftp/spegla/pkg-descr b/ftp/spegla/pkg-descr
new file mode 100644
index 000000000000..5e56d3d9a398
--- /dev/null
+++ b/ftp/spegla/pkg-descr
@@ -0,0 +1,52 @@
+Spegla is a mirror program for FTP sites. It was written because I
+couldn't find any fast mirroring program for big mirrors. It makes a
+complete mirror of a FTP area.
+
+Spegla only take one command-line parameter, the config file. These
+parameters can be specified in it:
+
+ - localdir where the mirror should go on your machine.
+
+ - remotedir directory at the FTP server.
+
+ - username user to log in as i.e. anonymous.
+
+ - password password to use i.e. your email address.
+
+ - host FTP server.
+
+ - retries how many retries before quit. Defaults to 20.
+
+ - retrytime how many seconds to wait before log in again after
+ a timeout. Defaults to 150.
+
+ - timeout how many seconds to wait to timeout. Defaults to 150.
+
+ - skipdir which directories to ignore remote and local, can be
+ several but only one per row.
+
+ - dirlink not used for now.
+
+ - logfile logfile, can be a file, stdout or stderr. Defaults
+ to stdout.
+
+Blank lines and text after '#' are ignored.
+
+This is what's in the config file I use for the FreeBSD mirror of
+Walnut Creek's FreeBSD area.
+
+localdir = /ftp/pub/FreeBSD
+remotedir = /pub/FreeBSD
+username = anonymous
+password = jnilsson@ludd.luth.se
+host = ftp.freebsd.org
+timeout = 120
+retries = 300 # busy ftp server and lots of files.
+ # Takes lots of hours to complete
+ # and don't want to quit when we are
+ # almost finished.
+retrytime = 120 # if network goes down don't consume
+ # all retries to fast.
+logfile = freebsd.org.log
+skipdir = distfiles # don't have room for this yet.
+skipdir = incoming # no need for this.
diff --git a/ftp/spegla/pkg-plist b/ftp/spegla/pkg-plist
new file mode 100644
index 000000000000..16f1690995e6
--- /dev/null
+++ b/ftp/spegla/pkg-plist
@@ -0,0 +1,3 @@
+bin/spegla
+share/examples/spegla/freebsd.org
+@dirrm share/examples/spegla