aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/vsftpd-ext
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2011-12-21 21:19:37 +0800
committerscheidell <scheidell@FreeBSD.org>2011-12-21 21:19:37 +0800
commit66d631fa4ac98d5982fcfadbc5be985ecb619fbf (patch)
tree9e0eca29d0265022bf135016e41abd932f1ddc0b /ftp/vsftpd-ext
parent326c417bb2adeb45eeba7f091978654f316d7e75 (diff)
downloadfreebsd-ports-gnome-66d631fa4ac98d5982fcfadbc5be985ecb619fbf.tar.gz
freebsd-ports-gnome-66d631fa4ac98d5982fcfadbc5be985ecb619fbf.tar.zst
freebsd-ports-gnome-66d631fa4ac98d5982fcfadbc5be985ecb619fbf.zip
- extra files, missed by committer
PR: ports/163246 Approved by: gabor (mentor)
Diffstat (limited to 'ftp/vsftpd-ext')
-rw-r--r--ftp/vsftpd-ext/files/patch-Makefile14
-rw-r--r--ftp/vsftpd-ext/files/patch-sysdeputil.c31
2 files changed, 45 insertions, 0 deletions
diff --git a/ftp/vsftpd-ext/files/patch-Makefile b/ftp/vsftpd-ext/files/patch-Makefile
new file mode 100644
index 000000000000..3820ca11f25f
--- /dev/null
+++ b/ftp/vsftpd-ext/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- ./Makefile.orig 2011-12-13 10:14:07.000000000 +0200
++++ ./Makefile 2011-12-13 10:15:30.000000000 +0200
+@@ -3,9 +3,9 @@
+ INSTALL = install
+ IFLAGS = -idirafter dummyinc
+ #CFLAGS = -g
+-CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
++CFLAGS = -O2 -pipe -march=prescott -fno-strict-aliasing -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
+
+-LIBS = -lcap -ldl -lcrypt -lpam -lwrap -lnsl -lssl -lcrypto
++LIBS= -lpam
+ # | | + VSF_BUILD_SSL
+ # | + VSF_BUILD_TCPWRAPPERS
+ # + VSF_BUILD_PAM
diff --git a/ftp/vsftpd-ext/files/patch-sysdeputil.c b/ftp/vsftpd-ext/files/patch-sysdeputil.c
new file mode 100644
index 000000000000..becc2bdb4970
--- /dev/null
+++ b/ftp/vsftpd-ext/files/patch-sysdeputil.c
@@ -0,0 +1,31 @@
+--- sysdeputil.c.orig 2010-03-26 06:25:33.000000000 +0300
++++ sysdeputil.c 2011-05-17 20:51:35.350022421 +0400
+@@ -57,7 +57,7 @@
+ #endif
+ #define VSF_SYSDEP_HAVE_SHADOW
+ #define VSF_SYSDEP_HAVE_USERSHELL
+-#define VSF_SYSDEP_HAVE_LIBCAP
++#undef VSF_SYSDEP_HAVE_LIBCAP
+ #define VSF_SYSDEP_HAVE_UTMPX
+
+ #define __USE_GNU
+@@ -1213,7 +1213,9 @@ vsf_insert_uwtmp(const struct mystr* p_u
+ setutxent();
+ (void) pututxline(&s_utent);
+ endutxent();
++#if !defined(__FreeBSD__)
+ updwtmpx(WTMPX_FILE, &s_utent);
++#endif
+ }
+
+ void
+@@ -1232,7 +1234,9 @@ vsf_remove_uwtmp(void)
+ (void) pututxline(&s_utent);
+ endutxent();
+ s_utent.ut_tv.tv_sec = vsf_sysutil_get_time_sec();
++#if !defined(__FreeBSD__)
+ updwtmpx(WTMPX_FILE, &s_utent);
++#endif
+ }
+
+ #endif /* !VSF_SYSDEP_HAVE_UTMPX */