aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/vsftpd/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-05-02 07:14:18 +0800
committerpav <pav@FreeBSD.org>2011-05-02 07:14:18 +0800
commit59899a15896e8222fdf4f63699423e6c16c7e13d (patch)
tree770841835c57cb80a261d533c4c839bb07e1de25 /ftp/vsftpd/Makefile
parent39240f6848c9d49d7f4247fcc57bd39831c36c13 (diff)
downloadfreebsd-ports-gnome-59899a15896e8222fdf4f63699423e6c16c7e13d.tar.gz
freebsd-ports-gnome-59899a15896e8222fdf4f63699423e6c16c7e13d.tar.zst
freebsd-ports-gnome-59899a15896e8222fdf4f63699423e6c16c7e13d.zip
- Mark BROKEN on 9-CURRENT: does not compile
sysdeputil.c:611: error: 'cap_t' undeclared (first use in this function) [..] Reported by: pointyhat - While here, remove 6.X specific conditional
Diffstat (limited to 'ftp/vsftpd/Makefile')
-rw-r--r--ftp/vsftpd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/ftp/vsftpd/Makefile b/ftp/vsftpd/Makefile
index 5926bc0f1b8a..b5f35d227892 100644
--- a/ftp/vsftpd/Makefile
+++ b/ftp/vsftpd/Makefile
@@ -31,14 +31,15 @@ OPTIONS= RC_NG "install RC_NG script" off \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 900000
+BROKEN= does not compile on FreeBSD 9.X
+.endif
+
.if defined(WITH_RC_NG)
USE_RC_SUBR= vsftpd.sh
.endif
.if defined(WITH_VSFTPD_SSL) && !defined(WITHOUT_SSL)
-.if ${OSVERSION} < 700000
-WITH_OPENSSL_PORT= yes
-.endif
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
SSL_SUFFIX= -ssl
CFLAGS+= -I${OPENSSLINC}