aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wget+ipv6
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-12-17 13:15:58 +0800
committersf <sf@FreeBSD.org>2001-12-17 13:15:58 +0800
commit260bb145c740bda627ecb843f5d902ed6ca243b6 (patch)
tree697d5e15a017ccd2432985511df28e9a76ce3aa0 /ftp/wget+ipv6
parent996295c00e7aac5bb808a3d07cae0f821c67f4a1 (diff)
downloadfreebsd-ports-gnome-260bb145c740bda627ecb843f5d902ed6ca243b6.tar.gz
freebsd-ports-gnome-260bb145c740bda627ecb843f5d902ed6ca243b6.tar.zst
freebsd-ports-gnome-260bb145c740bda627ecb843f5d902ed6ca243b6.zip
add wget+ipv6, a bit old wget but capable to speak IPv6.
Due to radical development of wget, KAME patch would always not be released in short. This port will happily retire when wget aquires ability to speak IPv6 itself.
Diffstat (limited to 'ftp/wget+ipv6')
-rw-r--r--ftp/wget+ipv6/Makefile60
-rw-r--r--ftp/wget+ipv6/distinfo2
-rw-r--r--ftp/wget+ipv6/files/patch-ac11
-rw-r--r--ftp/wget+ipv6/files/patch-host.c11
-rw-r--r--ftp/wget+ipv6/files/patch-retr.c21
-rw-r--r--ftp/wget+ipv6/pkg-comment1
-rw-r--r--ftp/wget+ipv6/pkg-descr3
-rw-r--r--ftp/wget+ipv6/pkg-plist26
8 files changed, 135 insertions, 0 deletions
diff --git a/ftp/wget+ipv6/Makefile b/ftp/wget+ipv6/Makefile
new file mode 100644
index 000000000000..df3a9703779b
--- /dev/null
+++ b/ftp/wget+ipv6/Makefile
@@ -0,0 +1,60 @@
+# Ports collection makefile for: wget+ipv6
+# Date created: 17 Dec 2001
+# Whom: FUJISHIMA Satsuki <sf@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wget
+PORTVERSION= 1.7
+CATEGORIES= ftp www ipv6
+MASTER_SITES= ${MASTER_SITE_GNU} \
+ ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
+ ftp://ftp.informatik.hu-berlin.de/gnu/wget/ \
+ ftp://ftp.uni-mainz.de/pub/gnu/wget/ \
+ ftp://ftp.max.irk.ru/unix/net/www/wget/
+MASTER_SITE_SUBDIR= wget
+PKGNAMESUFFIX= +ipv6
+
+PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/kame/misc/&,}
+PATCHFILES= wget-17-v6-20010716a.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= sf@FreeBSD.org
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+BUILD_DEPENDS= giconv:${PORTSDIR}/converters/libiconv
+
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
+.endif
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
+
+MAN1= wget.1
+
+post-patch:
+# made by broken KAME patch. Already contacted.
+ @${RM} -f ${WRKSRC}/po/zh.po*
+# we don't need to run autoconf.
+ ${TOUCH} ${WRKSRC}/configure
+# convert utf-8 to Big5 for FreeBSD's default old fashioned gettext.
+ (cd ${WRKSRC}; \
+ ${MV} po/zh_TW.po po/zh_TW.po.utf-8; \
+ ${LOCALBASE}/bin/giconv -f UTF-8 -t BIG5 po/zh_TW.po.utf-8 |\
+ ${SED} -e 's/utf-8/big5/' |\
+ ${PERL} -p -e 's{([\x81-\xfe])\\}{$$1\\\\}g' |\
+ ${PERL} -p -e 's,\\\\([nt\"]),\\$$1,g' \
+ > po/zh_TW.po)
+
+pre-build:
+ @${RM} -f ${WRKSRC}/doc/wget.info*
+
+post-install:
+ install-info ${PREFIX}/info/wget.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/ftp/wget+ipv6/distinfo b/ftp/wget+ipv6/distinfo
new file mode 100644
index 000000000000..97763e456b6d
--- /dev/null
+++ b/ftp/wget+ipv6/distinfo
@@ -0,0 +1,2 @@
+MD5 (wget-1.7.tar.gz) = c911a6b937c0a18757d3211fb62831de
+MD5 (wget-17-v6-20010716a.diff.gz) = 95664b130be966834f7770d66d03654b
diff --git a/ftp/wget+ipv6/files/patch-ac b/ftp/wget+ipv6/files/patch-ac
new file mode 100644
index 000000000000..5fba79b376b3
--- /dev/null
+++ b/ftp/wget+ipv6/files/patch-ac
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Sun Dec 31 14:07:09 2000
++++ doc/Makefile.in Mon Jan 15 04:52:47 2001
+@@ -22,7 +22,7 @@
+ SHELL = /bin/sh
+
+ # Program to format Texinfo source into Info files.
+-MAKEINFO = @MAKEINFO@
++MAKEINFO = @MAKEINFO@ --no-split
+ # Program to format Texinfo source into DVI files.
+ TEXI2DVI = texi2dvi
+ # Program to convert DVI files to PostScript
diff --git a/ftp/wget+ipv6/files/patch-host.c b/ftp/wget+ipv6/files/patch-host.c
new file mode 100644
index 000000000000..9495ff9ec250
--- /dev/null
+++ b/ftp/wget+ipv6/files/patch-host.c
@@ -0,0 +1,11 @@
+--- src/host.c.orig Thu Aug 9 10:11:56 2001
++++ src/host.c Thu Aug 9 10:12:27 2001
+@@ -106,7 +106,7 @@
+
+ hp = gethostbyname2(name, af);
+ if (!hp) {
+- if (inet_pton(af, name, addr) != -1) {
++ if (inet_pton(af, name, addr) == 1) {
+ switch (af) {
+ case AF_INET:
+ socksize = sizeof (struct sockaddr_in);
diff --git a/ftp/wget+ipv6/files/patch-retr.c b/ftp/wget+ipv6/files/patch-retr.c
new file mode 100644
index 000000000000..dac6d57d6591
--- /dev/null
+++ b/ftp/wget+ipv6/files/patch-retr.c
@@ -0,0 +1,21 @@
+--- src/retr.c.orig Wed Feb 9 00:18:45 2000
++++ src/retr.c Wed Feb 9 00:18:51 2000
+@@ -445,7 +445,7 @@
+ recursive_reset ();
+ for (cur_url = url_list; cur_url; cur_url = cur_url->next, ++*count)
+ {
+- char *filename, *new_file;
++ char *filename, *new_file, *referer;
+ int dt;
+
+ if (opt.quota && opt.downloaded > opt.quota)
+@@ -453,7 +453,8 @@
+ status = QUOTEXC;
+ break;
+ }
+- status = retrieve_url (cur_url->url, &filename, &new_file, NULL, &dt);
++ referer = getenv("referer");
++ status = retrieve_url (cur_url->url, &filename, &new_file, referer, &dt);
+ if (opt.recursive && status == RETROK && (dt & TEXTHTML))
+ status = recursive_retrieve (filename, new_file ? new_file : cur_url->url);
+
diff --git a/ftp/wget+ipv6/pkg-comment b/ftp/wget+ipv6/pkg-comment
new file mode 100644
index 000000000000..f8926ada48c0
--- /dev/null
+++ b/ftp/wget+ipv6/pkg-comment
@@ -0,0 +1 @@
+Retrieve files from the 'net via HTTP and FTP with IPv6 capability
diff --git a/ftp/wget+ipv6/pkg-descr b/ftp/wget+ipv6/pkg-descr
new file mode 100644
index 000000000000..a2979b22d241
--- /dev/null
+++ b/ftp/wget+ipv6/pkg-descr
@@ -0,0 +1,3 @@
+wget+ipv6 is wget with IPv6 capability by KAME patch.
+
+WWW: http://sunsite.auc.dk/wget/
diff --git a/ftp/wget+ipv6/pkg-plist b/ftp/wget+ipv6/pkg-plist
new file mode 100644
index 000000000000..96543579d40c
--- /dev/null
+++ b/ftp/wget+ipv6/pkg-plist
@@ -0,0 +1,26 @@
+bin/wget
+etc/wgetrc
+@unexec install-info --delete %D/info/wget.info %D/info/dir
+info/wget.info
+@exec install-info %D/info/wget.info %D/info/dir
+share/locale/cs/LC_MESSAGES/wget.mo
+share/locale/da/LC_MESSAGES/wget.mo
+share/locale/de/LC_MESSAGES/wget.mo
+share/locale/el/LC_MESSAGES/wget.mo
+share/locale/es/LC_MESSAGES/wget.mo
+share/locale/et/LC_MESSAGES/wget.mo
+share/locale/fr/LC_MESSAGES/wget.mo
+share/locale/gl/LC_MESSAGES/wget.mo
+share/locale/hr/LC_MESSAGES/wget.mo
+share/locale/it/LC_MESSAGES/wget.mo
+share/locale/ja/LC_MESSAGES/wget.mo
+share/locale/nl/LC_MESSAGES/wget.mo
+share/locale/no/LC_MESSAGES/wget.mo
+share/locale/pl/LC_MESSAGES/wget.mo
+share/locale/pt_BR/LC_MESSAGES/wget.mo
+share/locale/ru/LC_MESSAGES/wget.mo
+share/locale/sk/LC_MESSAGES/wget.mo
+share/locale/sl/LC_MESSAGES/wget.mo
+share/locale/sv/LC_MESSAGES/wget.mo
+share/locale/tr/LC_MESSAGES/wget.mo
+share/locale/zh_TW/LC_MESSAGES/wget.mo