aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wget/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2005-06-10 16:14:48 +0800
committersf <sf@FreeBSD.org>2005-06-10 16:14:48 +0800
commitc13350595599082a7a8790ea5985df6ce56dce72 (patch)
tree551aa00f21d3400bd3f997bbfcab8e2282a73300 /ftp/wget/Makefile
parent8322dc3ea0aa955f65857b6be373e99554c1eabb (diff)
downloadfreebsd-ports-gnome-c13350595599082a7a8790ea5985df6ce56dce72.tar.gz
freebsd-ports-gnome-c13350595599082a7a8790ea5985df6ce56dce72.tar.zst
freebsd-ports-gnome-c13350595599082a7a8790ea5985df6ce56dce72.zip
update to 1.10.
Diffstat (limited to 'ftp/wget/Makefile')
-rw-r--r--ftp/wget/Makefile35
1 files changed, 15 insertions, 20 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index b99e64b12742..d1dad95af350 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -5,21 +5,12 @@
# $FreeBSD$
#
-# NOTE: I would like to skip wget-1.9 and wait for stabilization.
-# Please don't push me to update. Thank you.
-
PORTNAME= wget
-PORTVERSION= 1.8.2
-PORTREVISION= 7
+DISTVERSION= 1.10
CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= wget
-PATCH_SITES= ${MASTER_SITE_LOCAL}
-PATCH_SITE_SUBDIR= sf
-PATCHFILES= wget_${PORTVERSION}-12.diff.gz
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= sf@FreeBSD.org
COMMENT= Retrieve files from the Net via HTTP and FTP
@@ -27,33 +18,37 @@ COMMENT= Retrieve files from the Net via HTTP and FTP
USE_GETTEXT= yes
.endif
-CONFLICTS= wget-devel-*
+CONFLICTS= wget-devel-[0-9]*
-USE_REINPLACE= yes
+USE_REINPLACE= yes
USE_PERL5_BUILD= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS= --with-ssl=no
.else
USE_OPENSSL= yes
.endif
-CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
- LIBS=-L${LOCALBASE}/lib
-PLIST_SUB= NLS=""
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
+.else
+CONFIGURE_ARGS+= --enable-nls
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ "LDFLAGS=${LDFLAGS}"
+PLIST_SUB= NLS=""
.endif
MAN1= wget.1
INFO= wget
post-patch:
- ${RM} -f ${WRKSRC}/doc/wget.info*
-# we don't need to run autoconf.
- ${TOUCH} ${WRKSRC}/configure
+ ${RM} -f ${WRKSRC}/doc/wget.info* ${WRKSRC}/po/*.mo ${WRKSRC}/po/*.gmo
+# eliminate gmakism
+ ${REINPLACE_CMD} -e 's,$$<,$$(srcdir)/wget.texi,' \
+ ${WRKSRC}/doc/Makefile.in
${REINPLACE_CMD} -e 's,/etc/wgetrc,${PREFIX}/etc/wgetrc,' \
-e 's,@file{},@file{${PREFIX}},' \
${WRKSRC}/doc/sample.wgetrc* ${WRKSRC}/doc/wget.texi