aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wget/files
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-12-19 03:47:45 +0800
committersf <sf@FreeBSD.org>2001-12-19 03:47:45 +0800
commit56c054d4b51b7d0be64c2ac1214619c8dffcb9b9 (patch)
tree8570f8ea844ab390a44691b26b50a04ffa62b0bc /ftp/wget/files
parentdd7e903fd18ab1a07d706b5d47159d695698c5bf (diff)
downloadfreebsd-ports-gnome-56c054d4b51b7d0be64c2ac1214619c8dffcb9b9.tar.gz
freebsd-ports-gnome-56c054d4b51b7d0be64c2ac1214619c8dffcb9b9.tar.zst
freebsd-ports-gnome-56c054d4b51b7d0be64c2ac1214619c8dffcb9b9.zip
Today's daily wget:
o don't detect libmd5 in libwww. o pass Referer header in recursive retrieval. Obtained from: wget CVS
Diffstat (limited to 'ftp/wget/files')
-rw-r--r--ftp/wget/files/patch-configure.in32
-rw-r--r--ftp/wget/files/patch-src_recur.c17
2 files changed, 49 insertions, 0 deletions
diff --git a/ftp/wget/files/patch-configure.in b/ftp/wget/files/patch-configure.in
new file mode 100644
index 000000000000..aab0684fbb72
--- /dev/null
+++ b/ftp/wget/files/patch-configure.in
@@ -0,0 +1,32 @@
+Index: configure.in
+===================================================================
+RCS file: /pack/anoncvs/wget/configure.in,v
+retrieving revision 1.30
+retrieving revision 1.31
+diff -u -r1.30 -r1.31
+--- configure.in 2001/12/06 10:45:26 1.30
++++ configure.in 2001/12/11 06:20:22 1.31
+@@ -340,18 +340,18 @@
+ dnl Find an md5 implementation.
+ dnl
+
+-dnl On Solaris, we use libmd5. If we're compiled with OpenSSL, use
+-dnl OpenSSL's md5 support. Otherwise, use our own md5.
+-
+ if test x$wget_need_md5 = xyes
+ then
+ MD5_OBJ='gen-md5$o'
+
+ found_md5=no
+
+- dnl First check for Solaris md5.
++ dnl Check for the system MD5 library on Solaris. We don't check for
++ dnl something simple like "MD5Update" because there are a number of
++ dnl MD5 implementations that use that name. md5_calc is, hopefully,
++ dnl specific to the Solaris MD5 library.
+ if test x$found_md5 = xno; then
+- AC_CHECK_LIB(md5, MD5Update, [
++ AC_CHECK_LIB(md5, md5_calc, [
+ AC_DEFINE(HAVE_SOLARIS_MD5)
+ LIBS="-lmd5 $LIBS"
+ found_md5=yes
diff --git a/ftp/wget/files/patch-src_recur.c b/ftp/wget/files/patch-src_recur.c
new file mode 100644
index 000000000000..a7cfd8800b0c
--- /dev/null
+++ b/ftp/wget/files/patch-src_recur.c
@@ -0,0 +1,17 @@
+Index: src/recur.c
+===================================================================
+RCS file: /pack/anoncvs/wget/src/recur.c,v
+retrieving revision 1.37
+retrieving revision 1.38
+diff -u -r1.37 -r1.38
+--- src/recur.c 2001/12/13 19:18:31 1.37
++++ src/recur.c 2001/12/18 15:22:03 1.38
+@@ -237,7 +237,7 @@
+ int oldrec = opt.recursive;
+
+ opt.recursive = 0;
+- status = retrieve_url (url, &file, &redirected, NULL, &dt);
++ status = retrieve_url (url, &file, &redirected, referer, &dt);
+ opt.recursive = oldrec;
+
+ if (file && status == RETROK