aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wget
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2014-02-14 19:25:46 +0800
committervd <vd@FreeBSD.org>2014-02-14 19:25:46 +0800
commit6d2828f1ae84f7fdd47c131a8b3952b1c7f283bc (patch)
treef291ee82595d681b7881633e6fe4f86c1743c04c /ftp/wget
parent7a71e8296e559adfc4a45151351317f23f0ed438 (diff)
downloadfreebsd-ports-gnome-6d2828f1ae84f7fdd47c131a8b3952b1c7f283bc.tar.gz
freebsd-ports-gnome-6d2828f1ae84f7fdd47c131a8b3952b1c7f283bc.tar.zst
freebsd-ports-gnome-6d2828f1ae84f7fdd47c131a8b3952b1c7f283bc.zip
ftp/wget: Use LIB_DEPENDS in the form of lib<name>.so
https://wiki.freebsd.org/ports/fix_lib_depends PR: ports/186718 Submitted by: Eero Hänninen <fax@nohik.ee>
Diffstat (limited to 'ftp/wget')
-rw-r--r--ftp/wget/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 092b129895d0..8535c15f65ed 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-ssl=openssl
CPPFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
.elif ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+=--with-ssl=gnutls
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -58,7 +58,7 @@ PLIST_SUB= NLS="@comment "
.endif
.if ${PORT_OPTIONS:MIDN}
-LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
CONFIGURE_ARGS+=--enable-iri --with-libidn=${LOCALBASE}
USES+= iconv
.else
@@ -67,7 +67,7 @@ CONFIGURE_ARGS+=--disable-iri
.if ${PORT_OPTIONS:MPCRE}
# Wget will pick pcre automatically and link with it if it is present.
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.else