aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wput/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-12-08 18:13:10 +0800
committerkrion <krion@FreeBSD.org>2003-12-08 18:13:10 +0800
commit69b5be18665902df0b9c0a33b619fc8907041390 (patch)
tree0785424eef6f3e190ce7e873b742954d821f723f /ftp/wput/Makefile
parent28e0ef6c75379c8291841f49f964041e92628d6e (diff)
downloadfreebsd-ports-gnome-69b5be18665902df0b9c0a33b619fc8907041390.tar.gz
freebsd-ports-gnome-69b5be18665902df0b9c0a33b619fc8907041390.tar.zst
freebsd-ports-gnome-69b5be18665902df0b9c0a33b619fc8907041390.zip
Add wput 0.3.6,
wput is a tiny program that looks like wget and does as the name suggests exactly the opposite: it uploads files or recursivly whole directories to a ftp-server and supports resuming. PR: 60032 Submitted by: Nosov Artem <chip-set@mail.ru>
Diffstat (limited to 'ftp/wput/Makefile')
-rw-r--r--ftp/wput/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
new file mode 100644
index 000000000000..09ef17a46e3a
--- /dev/null
+++ b/ftp/wput/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: wput
+# Date created: 2 December 2003
+# Whom: Nosov Artem <chip-set@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wput
+PORTVERSION= 0.3.6
+CATEGORIES= ftp
+MASTER_SITES= http://itooktheredpill.dyndns.org/wput/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= chip-set@mail.ru
+COMMENT= Uploads files or directories to a ftpserver with support of resuming
+
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in USAGE.examples TODO
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>