aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wput
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-26 17:58:33 +0800
committerbapt <bapt@FreeBSD.org>2013-03-26 17:58:33 +0800
commit512b099b0e8162a661f66142e440e6deda9c754f (patch)
tree0703b05c980a1a962f207fe4415499f2f3f22ae8 /ftp/wput
parent399e8c4c349f1b9f4bacd9c9976acd8b96fe1bce (diff)
downloadfreebsd-ports-gnome-512b099b0e8162a661f66142e440e6deda9c754f.tar.gz
freebsd-ports-gnome-512b099b0e8162a661f66142e440e6deda9c754f.tar.zst
freebsd-ports-gnome-512b099b0e8162a661f66142e440e6deda9c754f.zip
Convert left unconverted ports in ftp to new options framework
Diffstat (limited to 'ftp/wput')
-rw-r--r--ftp/wput/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
index d0f60eaabf85..e2b3eef8fdc1 100644
--- a/ftp/wput/Makefile
+++ b/ftp/wput/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wput
-# Date created: 2 December 2003
-# Whom: Nosov Artem <chip-set@mail.ru>
-#
+# Created by: Nosov Artem <chip-set@mail.ru>
# $FreeBSD$
-#
PORTNAME= wput
PORTVERSION= 0.6.2
@@ -24,21 +20,21 @@ CONFIGURE_ENV= LIBS="${LDFLAGS}"
CFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE=yes
-OPTIONS= TLS "Enable TLS support" On \
- NLS "Native Language Support with gettext" On
+OPTIONS_DEFINE= TLS NLS DOCS EXAMPLES
+OPTIONS_DEFAULT= TLS
MAN1= wdel.1 wput.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_TLS)
+.if ${PORT_OPTIONS:MTLS}
LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --with-ssl
.else
CONFIGURE_ARGS+= --without-ssl
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_ICONV= yes
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls \
@@ -58,14 +54,14 @@ pre-configure:
post-install:
@${INSTALL_MAN} ${MAN1:S,^,${WRKSRC}/doc/,} ${MANPREFIX}/man/man1/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${INSTALL} -d ${EXAMPLESDIR}
@${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/doc/,} ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>