aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wzdftpd
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-02-23 05:52:51 +0800
committernovel <novel@FreeBSD.org>2006-02-23 05:52:51 +0800
commit673074ded50ae72054e23dec35303ed0bff09281 (patch)
treec580de32330a14da98840d83f5cf9d359beb16ee /ftp/wzdftpd
parent8b0f5e327bfb85eb4e444d057a7d2cb0e44d10cf (diff)
downloadfreebsd-ports-gnome-673074ded50ae72054e23dec35303ed0bff09281.tar.gz
freebsd-ports-gnome-673074ded50ae72054e23dec35303ed0bff09281.tar.zst
freebsd-ports-gnome-673074ded50ae72054e23dec35303ed0bff09281.zip
- Add zeroconf support via howl or avahi [1]
- Prefer gnutls over openssl Based on a patch by: "Daniel S. Haischt" <me@daniel.stefan.haischt.name> [1]
Diffstat (limited to 'ftp/wzdftpd')
-rw-r--r--ftp/wzdftpd/Makefile33
-rw-r--r--ftp/wzdftpd/files/patch-modules-zeroconf-libwzd_zeroconf.c10
-rw-r--r--ftp/wzdftpd/pkg-plist1
3 files changed, 39 insertions, 5 deletions
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index d9b4d2406667..b55bf77b289f 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -21,22 +21,26 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= pkgconfig
-CONFIGURE_ARGS+= --without-pam --without-pgsql
+CONFIGURE_ARGS+= --without-pam --without-pgsql --disable-bonjour
+CONFIGURE_ENV= CPPFLAGS="${CPPLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= UTF8 "Enable UTF8 support" off \
TCL "Enable TCL support" off \
- SSL "Enable OpenSSL support" on \
- GNUTLS "Enable gnutls support" off \
+ SSL "Enable OpenSSL support" off \
+ GNUTLS "Enable gnutls support" on \
IPV6 "Enable IPv6 support" on \
PERL "Enable PERL support" off \
- MYSQL "Enable MYSQL backend" off
+ MYSQL "Enable MYSQL backend" off \
+ AVAHI "Enable Zeroconf support using Avahi" on \
+ HOWL "Enable Zeroconf support using Howl" off
MAN1= siteconfig.1 \
siteuptime.1 \
sitewho.1 \
- wzd-config.1
+ wzd-config.1
MAN8= wzdftpd.8
.include <bsd.port.pre.mk>
@@ -88,6 +92,24 @@ CONFIGURE_ARGS+= --without-mysql
PLIST_SUB+= MYSQL="@comment "
.endif
+.if defined(WITH_AVAHI) || defined(WITH_HOWL)
+PLIST_SUB+= ZEROCONF=""
+.else
+PLIST_SUB+= ZEROCONF="@comment "
+.endif
+
+.if defined(WITH_AVAHI) && !defined(WITH_HOWL)
+LIB_DEPENDS+= dbus-1.2:${PORTSDIR}/devel/dbus \
+ avahi-core.3:${PORTSDIR}/net/avahi
+CONFIGURE_ARGS+= --with-zeroconf --enable-avahi
+.endif
+
+.if defined(WITH_HOWL) && !defined(WITH_AVAHI)
+CFLAGS+= -I${LOCALBASE}/include/howl
+LIB_DEPENDS+= howl.0:${PORTSDIR}/net/howl
+CONFIGURE_ARGS+= --with-zeroconf --enable-howl
+.endif
+
PORTDOCS= AUTHORS Permissions.ReadMeFirst README TLS.ReadMeFirst ChangeLog
RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
@@ -95,6 +117,7 @@ RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
post-patch:
@${REINPLACE_CMD} -e "s|@HAVE_PERL_TRUE@|#|g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|" ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)
diff --git a/ftp/wzdftpd/files/patch-modules-zeroconf-libwzd_zeroconf.c b/ftp/wzdftpd/files/patch-modules-zeroconf-libwzd_zeroconf.c
new file mode 100644
index 000000000000..b86388677afd
--- /dev/null
+++ b/ftp/wzdftpd/files/patch-modules-zeroconf-libwzd_zeroconf.c
@@ -0,0 +1,10 @@
+--- modules/zeroconf/libwzd_zeroconf.c.orig Wed Feb 22 21:44:51 2006
++++ modules/zeroconf/libwzd_zeroconf.c Wed Feb 22 21:45:26 2006
+@@ -27,6 +27,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <string.h>
++#include <signal.h>
+
+ #include <arpa/inet.h> /* htonl() */
+ #include <sys/wait.h>
diff --git a/ftp/wzdftpd/pkg-plist b/ftp/wzdftpd/pkg-plist
index f6c4a8a74314..3605a72ffaf7 100644
--- a/ftp/wzdftpd/pkg-plist
+++ b/ftp/wzdftpd/pkg-plist
@@ -88,6 +88,7 @@ sbin/wzdftpd
%%DATADIR%%/modules/libwzd_sfv.so
%%PERL%%%%DATADIR%%/modules/libwzd_perl.so
%%TCL%%%%DATADIR%%/modules/libwzd_tcl.so
+%%ZEROCONF%%%%DATADIR%%/modules/libwzd_zeroconf.so
@dirrm %%DATADIR%%/modules/
@dirrm %%DATADIR%%/backends/
@dirrm %%DATADIR%%/