aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-01-10 00:39:53 +0800
committerscheidell <scheidell@FreeBSD.org>2012-01-10 00:39:53 +0800
commit0bff0126412a490b408691e212e367968e7e5285 (patch)
tree308036902ea7ada9319fe29767d9755b7bee9438 /ftp
parentbb01910ee8ea3f766ee7451e3d684cb825bce5c6 (diff)
downloadfreebsd-ports-gnome-0bff0126412a490b408691e212e367968e7e5285.tar.gz
freebsd-ports-gnome-0bff0126412a490b408691e212e367968e7e5285.tar.zst
freebsd-ports-gnome-0bff0126412a490b408691e212e367968e7e5285.zip
- Update to 2.3.5-ext1 [1]
- Fix path to vsftpd.conf in defs.h and builddefs.h old path /usr/local/etc/vsftpd.conf is not defined correctly [1] - patch-sysdeputil.c removed (FreeBSD already detected in sources) [1] PR: ports/163940 [1] Submitted by: Svyatoslav Lempert <svyatoslav.lempert@gmail.com> [1] Approved by: gelraen.ua@gmail.com (maintainer), gabor (mentor, implicit)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/vsftpd-ext/Makefile10
-rw-r--r--ftp/vsftpd-ext/distinfo4
-rw-r--r--ftp/vsftpd-ext/files/patch-sysdeputil.c31
3 files changed, 8 insertions, 37 deletions
diff --git a/ftp/vsftpd-ext/Makefile b/ftp/vsftpd-ext/Makefile
index df9f552b0144..c1f579a2febd 100644
--- a/ftp/vsftpd-ext/Makefile
+++ b/ftp/vsftpd-ext/Makefile
@@ -6,10 +6,7 @@
#
PORTNAME= vsftpd-ext
-UPSTREAMVERSION= 2.3.4
-EXTVERSION= 2
PORTVERSION= ${UPSTREAMVERSION}.${EXTVERSION}
-PORTREVISION= 1
CATEGORIES= ftp ipv6
MASTER_SITES= http://vsftpd.devnet.ru/files/${UPSTREAMVERSION}/ext.${EXTVERSION}/
PKGNAMESUFFIX?= ${SSL_SUFFIX}${PKGNAMESUFFIX2}
@@ -21,6 +18,9 @@ COMMENT= A FTP daemon that aims to be "very secure". Extended build
CONFLICTS= vsftpd-2* vsftpd${SSL_SUFFIX}${PKGNAMESUFFIX2}-2*
+UPSTREAMVERSION= 2.3.5
+EXTVERSION= 1
+
WRKSRC= ${WRKDIR}/vsFTPd-${UPSTREAMVERSION}-ext.${EXTVERSION}
ALL_TARGET= vsftpd
MAN5= vsftpd.conf.5
@@ -49,8 +49,10 @@ LDFLAGS+= -L${OPENSSLLIB}
.endif
do-configure:
- ${REINPLACE_CMD} -e "s|/etc/vsftpd.conf|${PREFIX}/etc/vsftpd.conf|" \
+ ${REINPLACE_CMD} -e "s|vsftpd.conf|${PREFIX}/etc/vsftpd.conf|" \
${WRKSRC}/defs.h ${WRKSRC}/vsftpd.conf
+ ${REINPLACE_CMD} -e "s|/etc/vsftpd|${PREFIX}/etc/vsftpd|" \
+ ${WRKSRC}/builddefs.h
${REINPLACE_CMD} \
-e '/^CC/s/=/?=/' \
-e '/^CFLAGS/{s/=/+=/;s/-O[0-9]//;}' \
diff --git a/ftp/vsftpd-ext/distinfo b/ftp/vsftpd-ext/distinfo
index 73c7c787d0f2..204dc2b07c81 100644
--- a/ftp/vsftpd-ext/distinfo
+++ b/ftp/vsftpd-ext/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vsFTPd-2.3.4-ext2.tgz) = 530aae6f3f32168fd2cac442483c63923df8e281dd0f351dd81593386b898ca0
-SIZE (vsFTPd-2.3.4-ext2.tgz) = 218473
+SHA256 (vsFTPd-2.3.5-ext1.tgz) = 2eeee4955565e6d6f9b21ab9a199689488d6d62c0024f6415dbd4510f85d43fe
+SIZE (vsFTPd-2.3.5-ext1.tgz) = 222249
diff --git a/ftp/vsftpd-ext/files/patch-sysdeputil.c b/ftp/vsftpd-ext/files/patch-sysdeputil.c
deleted file mode 100644
index becc2bdb4970..000000000000
--- a/ftp/vsftpd-ext/files/patch-sysdeputil.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- sysdeputil.c.orig 2010-03-26 06:25:33.000000000 +0300
-+++ sysdeputil.c 2011-05-17 20:51:35.350022421 +0400
-@@ -57,7 +57,7 @@
- #endif
- #define VSF_SYSDEP_HAVE_SHADOW
- #define VSF_SYSDEP_HAVE_USERSHELL
--#define VSF_SYSDEP_HAVE_LIBCAP
-+#undef VSF_SYSDEP_HAVE_LIBCAP
- #define VSF_SYSDEP_HAVE_UTMPX
-
- #define __USE_GNU
-@@ -1213,7 +1213,9 @@ vsf_insert_uwtmp(const struct mystr* p_u
- setutxent();
- (void) pututxline(&s_utent);
- endutxent();
-+#if !defined(__FreeBSD__)
- updwtmpx(WTMPX_FILE, &s_utent);
-+#endif
- }
-
- void
-@@ -1232,7 +1234,9 @@ vsf_remove_uwtmp(void)
- (void) pututxline(&s_utent);
- endutxent();
- s_utent.ut_tv.tv_sec = vsf_sysutil_get_time_sec();
-+#if !defined(__FreeBSD__)
- updwtmpx(WTMPX_FILE, &s_utent);
-+#endif
- }
-
- #endif /* !VSF_SYSDEP_HAVE_UTMPX */