aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-07-27 18:55:27 +0800
committereik <eik@FreeBSD.org>2004-07-27 18:55:27 +0800
commit4f4a43e56fd151e808ac4c238d716673098d2deb (patch)
treedea6b82eda42a5df2c5edbf54e6cb324fd27440a /ftp
parent6cd49fb364d3b752875ca91057ccb3ad05349d3d (diff)
downloadfreebsd-ports-gnome-4f4a43e56fd151e808ac4c238d716673098d2deb.tar.gz
freebsd-ports-gnome-4f4a43e56fd151e808ac4c238d716673098d2deb.tar.zst
freebsd-ports-gnome-4f4a43e56fd151e808ac4c238d716673098d2deb.zip
Fix <http://www.freebsd.org/ports/portaudit/f67ea071-dfb8-11d8-9b0a-000347a4fa7d.html>
Obtained from: gentoo cvs
Diffstat (limited to 'ftp')
-rw-r--r--ftp/pavuk/Makefile2
-rw-r--r--ftp/pavuk/files/patch-src::digest_auth.c30
2 files changed, 31 insertions, 1 deletions
diff --git a/ftp/pavuk/Makefile b/ftp/pavuk/Makefile
index 685b67ab69ca..4d778b76cdb7 100644
--- a/ftp/pavuk/Makefile
+++ b/ftp/pavuk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pavuk
PORTVERSION= 0.9.28
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= ftp www
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.idata.sk/~ondrej/sw/
diff --git a/ftp/pavuk/files/patch-src::digest_auth.c b/ftp/pavuk/files/patch-src::digest_auth.c
new file mode 100644
index 000000000000..8aa305958d1d
--- /dev/null
+++ b/ftp/pavuk/files/patch-src::digest_auth.c
@@ -0,0 +1,30 @@
+--- src/digest_auth_orig.c 2000-12-03 08:25:44.000000000 -0600
++++ src/digest_auth.c 2004-07-24 13:45:50.000000000 -0500
+@@ -87,6 +87,7 @@
+ return retv;
+ }
+
++/* PRE: Assumes 'buf' can store 2K */
+ char *http_get_digest_auth_str(auth_digest, method, user, pass, urlp, buf)
+ http_digest_info *auth_digest;
+ char *method;
+@@ -99,14 +100,15 @@
+ char *a1,*a2,*a3;
+ char *d = url_encode_str(urlp->p.http.document, URL_PATH_UNSAFE);
+
+- sprintf(pom, "%s:%s:%s", user, auth_digest->realm, pass);
++ snprintf(pom, sizeof(pom), "%s:%s:%s", user, auth_digest->realm, pass);
+ a1 = _md5(pom);
+- sprintf(pom, "%s:%s", method, d);
++ snprintf(pom, sizeof(pom), "%s:%s", method, d);
+ a2 = _md5(pom);
+- sprintf(pom, "%s:%s:%s", a1, auth_digest->nonce, a2);
++ snprintf(pom, sizeof(pom), "%s:%s:%s", a1, auth_digest->nonce, a2);
+ a3 = _md5(pom);
+
+- sprintf(buf,
++ snprintf(buf,
++ 2048,
+ "Digest username=\"%s\", realm=\"%s\", nonce=\"%s\", uri=\"%s\", response=\"%s\"" ,
+ user, auth_digest->realm, auth_digest->nonce, d, a3);
+