aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-08-04 22:38:03 +0800
committeracm <acm@FreeBSD.org>2006-08-04 22:38:03 +0800
commite3e2191bbd7bfaa997a88d05fa519836315e656e (patch)
tree37494c625460cc049807b13b1a408acaacc3942b /ftp
parentfbb3370bb7809d90f8dcbae979c433f8f6f2d0b0 (diff)
downloadfreebsd-ports-gnome-e3e2191bbd7bfaa997a88d05fa519836315e656e.tar.gz
freebsd-ports-gnome-e3e2191bbd7bfaa997a88d05fa519836315e656e.tar.zst
freebsd-ports-gnome-e3e2191bbd7bfaa997a88d05fa519836315e656e.zip
- New port: ftp/linux-curl
curl is a client to get documents/files from servers, using any of the supported protocols. The command is designed to work without user interaction or any kind of interactivity. curl offers a busload of useful tricks like proxy support, user authentication, ftp upload, HTTP post, SSL (https:) connections, file transfer resume and more. (Linux version) WWW: http://curl.haxx.se/ Approved by: garga (mentor)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/linux-curl/Makefile24
-rw-r--r--ftp/linux-curl/distinfo.i3866
-rw-r--r--ftp/linux-f10-curl/Makefile24
-rw-r--r--ftp/linux-f10-curl/distinfo.i3866
-rw-r--r--ftp/linux-f8-curl/Makefile24
-rw-r--r--ftp/linux-f8-curl/distinfo.i3866
7 files changed, 91 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 5deb25cb0e25..bbad45cafbfa 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -48,6 +48,7 @@
SUBDIR += kpum
SUBDIR += kwebget
SUBDIR += lftp
+ SUBDIR += linux-curl
SUBDIR += llnlxdir
SUBDIR += llnlxftp
SUBDIR += lukemftp
diff --git a/ftp/linux-curl/Makefile b/ftp/linux-curl/Makefile
new file mode 100644
index 000000000000..a153aec73284
--- /dev/null
+++ b/ftp/linux-curl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: linux-curl
+# Date created: 2006-08-04
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= curl
+PORTVERSION= 7.13.1
+CATEGORIES= ftp linux
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-5.fc4
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Curl linux version
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 4
+INSTALLS_SHLIB= yes
+AUTOMATIC_PLIST= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/ftp/linux-curl/distinfo.i386 b/ftp/linux-curl/distinfo.i386
new file mode 100644
index 000000000000..636b111cd295
--- /dev/null
+++ b/ftp/linux-curl/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = ee7edbd4508ba326e2448aa436d93cb4
+SHA256 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = ac29a2ea2fa3a78904573e41b51b457df2fa9f4b8228f303abcfcca864718e8e
+SIZE (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = 268613
+MD5 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 6bf9563972cc07ffed5f95b415e3818d
+SHA256 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 826bec1ba67dbb1ef2192b7b11d1a14dee6e44c8fb1e1fae3f0efc947efb1e3d
+SIZE (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 1879750
diff --git a/ftp/linux-f10-curl/Makefile b/ftp/linux-f10-curl/Makefile
new file mode 100644
index 000000000000..a153aec73284
--- /dev/null
+++ b/ftp/linux-f10-curl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: linux-curl
+# Date created: 2006-08-04
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= curl
+PORTVERSION= 7.13.1
+CATEGORIES= ftp linux
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-5.fc4
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Curl linux version
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 4
+INSTALLS_SHLIB= yes
+AUTOMATIC_PLIST= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/ftp/linux-f10-curl/distinfo.i386 b/ftp/linux-f10-curl/distinfo.i386
new file mode 100644
index 000000000000..636b111cd295
--- /dev/null
+++ b/ftp/linux-f10-curl/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = ee7edbd4508ba326e2448aa436d93cb4
+SHA256 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = ac29a2ea2fa3a78904573e41b51b457df2fa9f4b8228f303abcfcca864718e8e
+SIZE (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = 268613
+MD5 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 6bf9563972cc07ffed5f95b415e3818d
+SHA256 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 826bec1ba67dbb1ef2192b7b11d1a14dee6e44c8fb1e1fae3f0efc947efb1e3d
+SIZE (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 1879750
diff --git a/ftp/linux-f8-curl/Makefile b/ftp/linux-f8-curl/Makefile
new file mode 100644
index 000000000000..a153aec73284
--- /dev/null
+++ b/ftp/linux-f8-curl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: linux-curl
+# Date created: 2006-08-04
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= curl
+PORTVERSION= 7.13.1
+CATEGORIES= ftp linux
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-5.fc4
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Curl linux version
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 4
+INSTALLS_SHLIB= yes
+AUTOMATIC_PLIST= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/ftp/linux-f8-curl/distinfo.i386 b/ftp/linux-f8-curl/distinfo.i386
new file mode 100644
index 000000000000..636b111cd295
--- /dev/null
+++ b/ftp/linux-f8-curl/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = ee7edbd4508ba326e2448aa436d93cb4
+SHA256 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = ac29a2ea2fa3a78904573e41b51b457df2fa9f4b8228f303abcfcca864718e8e
+SIZE (rpm/i386/fedora/4/curl-7.13.1-5.fc4.i386.rpm) = 268613
+MD5 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 6bf9563972cc07ffed5f95b415e3818d
+SHA256 (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 826bec1ba67dbb1ef2192b7b11d1a14dee6e44c8fb1e1fae3f0efc947efb1e3d
+SIZE (rpm/i386/fedora/4/curl-7.13.1-5.fc4.src.rpm) = 1879750