aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-01-09 22:41:58 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-01-09 22:41:58 +0800
commit45136c6a689cc7f4fabbd4c8c2f4fb1a96e3baf0 (patch)
treec8c9b6aa401e40a54f81302062c3d5be8ff52bb8 /ftp
parent13d49c9f1e6388f7c5c8c5b791256c9f0158acf1 (diff)
downloadfreebsd-ports-gnome-45136c6a689cc7f4fabbd4c8c2f4fb1a96e3baf0.tar.gz
freebsd-ports-gnome-45136c6a689cc7f4fabbd4c8c2f4fb1a96e3baf0.tar.zst
freebsd-ports-gnome-45136c6a689cc7f4fabbd4c8c2f4fb1a96e3baf0.zip
Fix TLSCipherSuite parsing
- Bump PORTREVISION for package change Note: author pointed out that users will get a more secure cipher suite by not setting TLSCipherSuite to HIGH and just use the default. PR: 215906 Reported by: <yani@pi-greece.eu> Obtained from: https://github.com/jedisct1/pure-ftpd/commit/3823d00dee089b998d1f40943e9aa3f619c238b2
Diffstat (limited to 'ftp')
-rw-r--r--ftp/pure-ftpd/Makefile1
-rw-r--r--ftp/pure-ftpd/files/patch-src-simpleconf_ftpd.h14
2 files changed, 15 insertions, 0 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index e56ed0820290..6cbc6c364bd3 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pure-ftpd
PORTVERSION= 1.0.44
+PORTREVISION= 1
CATEGORIES= ftp ipv6
MASTER_SITES= https://github.com/jedisct1/${PORTNAME}/releases/download/${PORTVERSION}/ \
https://download.pureftpd.org/pub/pure-ftpd/releases/ \
diff --git a/ftp/pure-ftpd/files/patch-src-simpleconf_ftpd.h b/ftp/pure-ftpd/files/patch-src-simpleconf_ftpd.h
new file mode 100644
index 000000000000..b9fa7bec1aea
--- /dev/null
+++ b/ftp/pure-ftpd/files/patch-src-simpleconf_ftpd.h
@@ -0,0 +1,14 @@
+Obtained from: https://github.com/jedisct1/pure-ftpd/commit/3823d00dee089b998d1f40943e9aa3f619c238b2
+
+--- src/simpleconf_ftpd.h.orig 2016-12-16 19:17:52 UTC
++++ src/simpleconf_ftpd.h
+@@ -59,8 +59,8 @@ static const SimpleConfEntry simpleconf_
+ {"ProhibitDotFilesRead? <bool>", "--prohibitdotfilesread"},
+ {"Quota (<digits>):(<digits>)", "--quota=$0:$1"},
+ {"SyslogFacility (<alnum>)", "--syslogfacility=$0"},
+- {"TLS (<digits>)", "--tls=$0"},
+ {"TLSCipherSuite (<nospace>)", "--tlsciphersuite=$0"},
++ {"TLS (<digits>)", "--tls=$0"},
+ {"TrustedGID (<digits>)", "--trustedgid=$0"},
+ {"TrustedIP (<nospace>)", "--trustedip=$0"},
+ {"Umask (<digits>):(<digits>)", "--umask=$0:$1"},