aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2008-12-09 03:33:33 +0800
committersem <sem@FreeBSD.org>2008-12-09 03:33:33 +0800
commit0446afee44c09e8d06aedac8257e4aae49f03611 (patch)
tree02c617ec75abf21ef58ba3b75b3a608f26eaa35c /ftp
parent26f4ed3f0d24b3a4885a14060f56a47fc7d929a9 (diff)
downloadfreebsd-ports-gnome-0446afee44c09e8d06aedac8257e4aae49f03611.tar.gz
freebsd-ports-gnome-0446afee44c09e8d06aedac8257e4aae49f03611.tar.zst
freebsd-ports-gnome-0446afee44c09e8d06aedac8257e4aae49f03611.zip
- Fix CacheModule http
PR: ports/121644 Submitted by: Sergey Samitovsky <svs_at_nktv.mk.ua>
Diffstat (limited to 'ftp')
-rw-r--r--ftp/frox/Makefile2
-rw-r--r--ftp/frox/files/patch-src-cache.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index 7c62f7b1e089..cfe2ab16a457 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= frox
PORTVERSION= 0.7.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= http://www.hollo.org/frox/download/ \
http://frox.sourceforge.net/download/ \
diff --git a/ftp/frox/files/patch-src-cache.c b/ftp/frox/files/patch-src-cache.c
new file mode 100644
index 000000000000..0f2ebeab247c
--- /dev/null
+++ b/ftp/frox/files/patch-src-cache.c
@@ -0,0 +1,18 @@
+Apply patch
+
+
+Patch attached with submission follows:
+
+--- src/cache.c.orig 2008-03-12 16:56:10.000000000 +0200
++++ src/cache.c 2008-03-12 16:56:10.000000000 +0200
+@@ -364,7 +364,7 @@
+ int code;
+ sstr *msg;
+
+- if(!strcasecmp(config.cachemod, "Local") || !config.forcehttp) {
++ if(!strcasecmp(config.cachemod, "Local") || config.forcehttp) {
+ send_ccommand("SIZE", sstr_buf(filename));
+ get_message(&code, &msg);
+ if(code / 100 != 2) {
+
+