aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-12-31 10:27:05 +0800
committersteve <steve@FreeBSD.org>1999-12-31 10:27:05 +0800
commit70dc560a2f78a78aac4ab4785c141092c74db3a5 (patch)
treef736aaef6f66814a1afa46ca9ab9acbf483dceff /ftp
parenta20a1ff7dae39040dd227aa2045b11ffe958a5f7 (diff)
downloadfreebsd-ports-gnome-70dc560a2f78a78aac4ab4785c141092c74db3a5.tar.gz
freebsd-ports-gnome-70dc560a2f78a78aac4ab4785c141092c74db3a5.tar.zst
freebsd-ports-gnome-70dc560a2f78a78aac4ab4785c141092c74db3a5.zip
Adding sftp version 0.5.
An ftp(1) replacement that runs over an ssh tunnel. PR: 15777 Submitted by: Cy Shubert <Cy.Shubert@uumail.gov.bc.ca>
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/sftp/Makefile32
-rw-r--r--ftp/sftp/distinfo1
-rw-r--r--ftp/sftp/pkg-comment1
-rw-r--r--ftp/sftp/pkg-descr37
5 files changed, 72 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 3eac72676cce..413823ce2eff 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -25,6 +25,7 @@
SUBDIR += omi
SUBDIR += pavuk
SUBDIR += proftpd
+ SUBDIR += sftp
SUBDIR += spegla
SUBDIR += wget
SUBDIR += wu-ftpd
diff --git a/ftp/sftp/Makefile b/ftp/sftp/Makefile
new file mode 100644
index 000000000000..50751402111d
--- /dev/null
+++ b/ftp/sftp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: sftp
+# Version required: 0.5
+# Date created: 30 December 1999
+# Whom: Cy Shubert <Cy.Shubert@uumail.gov.bc.ca>
+#
+# $FreeBSD$
+#
+
+DISTNAME= sftp-0.5
+CATEGORIES= ftp security
+MASTER_SITES= ftp://ftp.xbill.org/pub/sftp/
+
+MAINTAINER= Cy.Schubert@uumail.gov.bc.ca
+
+RUN_DEPENDS= ssh:${PORTSDIR}/security/openssh
+
+RESTRICTED= "Calls external cryptographic routines."
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --enable-remotepath=${PREFIX}/libexec
+
+MAN1= sftp.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sftp ${PREFIX}/bin/sftp
+ ${LN} -s ${PREFIX}/bin/sftp ${PREFIX}/bin/rsftp
+ ${INSTALL_PROGRAM} ${WRKSRC}/sftpserv ${PREFIX}/libexec/sftpserv
+ ${INSTALL_MAN} ${WRKSRC}/sftp.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/ftp/sftp/distinfo b/ftp/sftp/distinfo
new file mode 100644
index 000000000000..1390ed2b22f6
--- /dev/null
+++ b/ftp/sftp/distinfo
@@ -0,0 +1 @@
+MD5 (sftp-0.5.tar.gz) = 8070983234f1a872b969f8eebe24b84d
diff --git a/ftp/sftp/pkg-comment b/ftp/sftp/pkg-comment
new file mode 100644
index 000000000000..002fe83242e4
--- /dev/null
+++ b/ftp/sftp/pkg-comment
@@ -0,0 +1 @@
+An ftp replacement that runs over an ssh tunnel
diff --git a/ftp/sftp/pkg-descr b/ftp/sftp/pkg-descr
new file mode 100644
index 000000000000..23a869a300b8
--- /dev/null
+++ b/ftp/sftp/pkg-descr
@@ -0,0 +1,37 @@
+sftp is an ftp replacement that runs over an ssh tunnel. Two programs are
+included - sftp and sftpserv. When sftp is run and a host is connected to
+(either by running 'sftp remotehost' or 'open remotehost' from the sftp
+prompt), an ssh connection is initiated to the remote host, and sftpserv is
+run. So, sftpserv must be in your path on the remote host. Note that since
+sftpserv is run from ssh, no root privileges are necessary. By default,
+sftpserv is expected to be in $PATH on the remote host. This can be overriden
+by passing '--enable-remotepath=<path>' to configure or using the
+'-P remotepath' option to sftp. To run as a different user, use the
+'-l remoteuser' option. To connect to an alternate port with ssh,
+use the '-p remoteport' option. To enable ssh compression, use '-C'.
+
+From within sftp, all of the normal ftp commands are present: open, close, get,
+put, mget, mput, cd, ls, dir, lcd, delete, rm, pwd, quit. There's also exec,
+which runs a program on the remote end. This program must not accept input
+('exec ls' is ok, but 'exec vi' is not). To run local commands, precede them
+with a '!'.
+
+When building sftp, a link is made to rsftp, which uses rsh instead of ssh.
+sftp has been tested with rsh (with and without .rhosts) and ssh1 (with
+ssh-agent, password, and RSA authentication). I haven't tested ssh2, but it
+should work. The login process is a bit of a hack, so if logging in doesn't
+work, it's a bug and should be fixed.
+
+sftp uses a fairly simple multiplexed protocol over an SSH channel. The server
+is a state machine, and is far more capable than the client. As an example,
+the server theoretically could handle multiple concurrent file transfers, but
+the client will only send one.
+
+This was mostly written during the summer of 1998, and resurrected in October,
+1999. I don't know how much time I want to spend adding new features, but
+bugs will be fixed.
+
+sftp is distributed under the GNU General Public License (GPL), Version 2.
+
+WWW: http://www.xbill.org/sftp
+Author: Brian Wellington (bwelling@xbill.org)