aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-05 04:01:05 +0800
committerbsam <bsam@FreeBSD.org>2013-09-05 04:01:05 +0800
commit7b5950ceb07fbf7baff9cf5f999cb870df39056d (patch)
tree293dcbc9c7e5b5460095f0f0b868e1ead9528ded /ftp
parentce8f3833463574b1140cd020d12c0b68cfcb0d83 (diff)
downloadfreebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.tar.gz
freebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.tar.zst
freebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.zip
Introduce ICONV_CONFIGURE_ARG variable defined at Uses/iconv.mk.
It's value is "--with-libiconv-prefix=/usr/local" for systems before 100043 with ports libiconv and to use at systems post 100043 with base iconv it's value is "" (NULL). Co-authors: bapt, madpilot and bsam (me)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wput/Makefile2
-rw-r--r--ftp/wzdftpd/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
index b2797864451b..a14950c40013 100644
--- a/ftp/wput/Makefile
+++ b/ftp/wput/Makefile
@@ -38,7 +38,7 @@ CONFIGURE_ARGS+= --without-ssl
USES+= gettext iconv
CONFIGURE_ARGS+= --enable-nls \
--with-libintl-prefix=${LOCALBASE} \
- --with-libiconv-prefix=${LOCALBASE}
+ ${ICONV_CONFIGURE_ARG}
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls --without-libiconv-prefix
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 62d3c78bcec6..22f71146e910 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -38,7 +38,7 @@ MAN8= wzdftpd.8
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
-CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG}
.else
CONFIGURE_ARGS+= --disable-utf8
.endif