aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
committerrafan <rafan@FreeBSD.org>2007-07-23 17:36:51 +0800
commitb028b113ef13fa7972bb45d681d7a0abe47c40a6 (patch)
treea76a27ca09341f754b493c264ee71c912a553d89 /ftp
parent855b1df39bc3a6f03abf878d9c99b5ba0838ba35 (diff)
downloadfreebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.gz
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.tar.zst
freebsd-ports-gnome-b028b113ef13fa7972bb45d681d7a0abe47c40a6.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Diffstat (limited to 'ftp')
-rw-r--r--ftp/axel/Makefile2
-rw-r--r--ftp/curl/Makefile1
-rw-r--r--ftp/lftp/Makefile2
-rw-r--r--ftp/pavuk/Makefile3
-rw-r--r--ftp/wxdfast/Makefile1
-rw-r--r--ftp/wzdftpd/Makefile2
6 files changed, 3 insertions, 8 deletions
diff --git a/ftp/axel/Makefile b/ftp/axel/Makefile
index 343c7a97e4c4..6cbc7a7460b8 100644
--- a/ftp/axel/Makefile
+++ b/ftp/axel/Makefile
@@ -18,7 +18,7 @@ COMMENT= A download accelerator
USE_GETTEXT= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${PREFIX}/man --i18n=1
+CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man --i18n=1
MAN1= axel.1
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index a21e298492f0..d4d61f453847 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -48,7 +48,6 @@ PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
CURL_DEBUG "Enable curl diagnostic output" off \
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 47906b76ae3b..0e959f64e28f 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -61,8 +61,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-CONFIGURE_ARGS+=--mandir="${MAN1PREFIX}/man"
-
MAN1= lftp.1 lftpget.1
post-install:
diff --git a/ftp/pavuk/Makefile b/ftp/pavuk/Makefile
index 28c6427bff5e..06718fdc44fb 100644
--- a/ftp/pavuk/Makefile
+++ b/ftp/pavuk/Makefile
@@ -21,8 +21,7 @@ USE_GNOME= gnometarget
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
- --with-locale-dir=${PREFIX}/share/locale \
+CONFIGURE_ARGS= --with-locale-dir=${PREFIX}/share/locale \
--disable-debug --disable-gnome --disable-js \
--enable-utf-8 --enable-threads
diff --git a/ftp/wxdfast/Makefile b/ftp/wxdfast/Makefile
index 3f0ff559f095..5a889bc8febf 100644
--- a/ftp/wxdfast/Makefile
+++ b/ftp/wxdfast/Makefile
@@ -19,7 +19,6 @@ USE_WX= 2.6
WX_CONF_ARGS= relative
WX_UNICODE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir="${MANPREFIX}/man"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= wxdfast.1
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 20a1f2ec3ae0..c6b03188d683 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -21,7 +21,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= pkgconfig ltverhack
-CONFIGURE_ARGS+= --without-pam --disable-pgsql --disable-bonjour --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS+= --without-pam --disable-pgsql --disable-bonjour
CONFIGURE_ENV= CPPFLAGS="${CPPLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}