aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2017-02-06 00:47:34 +0800
committervd <vd@FreeBSD.org>2017-02-06 00:47:34 +0800
commitbfe90e6a437e80e11b933fa4062a31e7b1e206c1 (patch)
tree4aef80567b52aefd47ca29687a076243af93ba13 /ftp
parent6cd4de5ed293d6dca189a72a252e448bcaef5a6f (diff)
downloadfreebsd-ports-gnome-bfe90e6a437e80e11b933fa4062a31e7b1e206c1.tar.gz
freebsd-ports-gnome-bfe90e6a437e80e11b933fa4062a31e7b1e206c1.tar.zst
freebsd-ports-gnome-bfe90e6a437e80e11b933fa4062a31e7b1e206c1.zip
ftp/wget: fix compilation error due to -R being passed to clang
gcc accepts -R, but clang needs -Wl,-R and since we are changing this, use the proper -Wl,-rpath. Reported by: Walter Schwarzenfeld, Barbara Guida, Jimmy Olgeni, Ken J.
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wget/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index ddbbb3e9b83d..e16d05122cdf 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -78,6 +78,7 @@ post-patch:
-e 's,@file{},@file{${PREFIX}},' \
${WRKSRC}/doc/sample.wgetrc* ${WRKSRC}/doc/wget.texi
${REINPLACE_CMD} -e '/ac_fn_c_check_header_mongrel.*uuid\/uuid.h/ d' \
+ -e 's|-R$$found_dir|-Wl,-rpath=$$found_dir|g' \
${WRKSRC}/configure
.include <bsd.port.pre.mk>