aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2017-03-27 02:52:35 +0800
committerbrnrd <brnrd@FreeBSD.org>2017-03-27 02:52:35 +0800
commitce60774a8e25608874fb2bbd7ccbe731bfd7edda (patch)
tree2a670d5330776d1b5d0f20e776dabd00c6739dbd /ftp
parent8c8c12b64b835d76bdfcbd8a81ff5f7ea90ff72f (diff)
downloadfreebsd-ports-gnome-ce60774a8e25608874fb2bbd7ccbe731bfd7edda.tar.gz
freebsd-ports-gnome-ce60774a8e25608874fb2bbd7ccbe731bfd7edda.tar.zst
freebsd-ports-gnome-ce60774a8e25608874fb2bbd7ccbe731bfd7edda.zip
ftp/proftpd: Fix mod_tls build with LibreSSL
- Remove IGNORE with LibreSSL SSL_DEFAULT - Add patch for mod_tls to build with LibreSSL PR: 217025 Approved by: maintainer timeout
Diffstat (limited to 'ftp')
-rw-r--r--ftp/proftpd/Makefile3
-rw-r--r--ftp/proftpd/files/patch-modules_mod__tls.c20
2 files changed, 20 insertions, 3 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 349c3b91ab03..643eb5bc947d 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -174,9 +174,6 @@ CONFIGURE_ARGS+= --with-libraries=${LIBDIRS}
.if ${SSL_DEFAULT:Mopenssl-devel}
BROKEN= Does not build with openssl-devel
.endif
-.if ${SSL_DEFAULT:Mlibressl*}
-BROKEN= Does not build with libressl
-.endif
.if !defined(_BUILDING_PROFTPD_MODULE)
diff --git a/ftp/proftpd/files/patch-modules_mod__tls.c b/ftp/proftpd/files/patch-modules_mod__tls.c
new file mode 100644
index 000000000000..b4c6104ba1d8
--- /dev/null
+++ b/ftp/proftpd/files/patch-modules_mod__tls.c
@@ -0,0 +1,20 @@
+--- modules/mod_tls.c.orig 2017-01-16 01:13:01 UTC
++++ modules/mod_tls.c
+@@ -609,7 +609,7 @@ static void tls_diags_cb(const SSL *ssl,
+ break;
+ #endif
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ case TLS_ST_OK:
+ #else
+ case SSL_ST_OK:
+@@ -633,7 +633,7 @@ static void tls_diags_cb(const SSL *ssl,
+
+ ssl_state = SSL_get_state(ssl);
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ if (ssl_state == TLS_ST_SR_CLNT_HELLO) {
+ #else
+ if (ssl_state == SSL3_ST_SR_CLNT_HELLO_A ||