aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-03-27 13:38:23 +0800
committerantoine <antoine@FreeBSD.org>2017-03-27 13:38:23 +0800
commitf2a57acd4b2568af55fb032f154fea9fdc539b37 (patch)
tree30de82202aa25f5d864e4c405214010d2dc7324f /ftp
parent3bbe1b22837721af2773a3b36d05be5bc748ce46 (diff)
downloadfreebsd-ports-gnome-f2a57acd4b2568af55fb032f154fea9fdc539b37.tar.gz
freebsd-ports-gnome-f2a57acd4b2568af55fb032f154fea9fdc539b37.tar.zst
freebsd-ports-gnome-f2a57acd4b2568af55fb032f154fea9fdc539b37.zip
Revert r436977, patch fails to apply
Reported by: pkg-fallout With hat: portmgr
Diffstat (limited to 'ftp')
-rw-r--r--ftp/proftpd/Makefile3
-rw-r--r--ftp/proftpd/files/patch-modules_mod__tls.c20
2 files changed, 3 insertions, 20 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 643eb5bc947d..349c3b91ab03 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -174,6 +174,9 @@ CONFIGURE_ARGS+= --with-libraries=${LIBDIRS}
.if ${SSL_DEFAULT:Mopenssl-devel}
BROKEN= Does not build with openssl-devel
.endif
+.if ${SSL_DEFAULT:Mlibressl*}
+BROKEN= Does not build with libressl
+.endif
.if !defined(_BUILDING_PROFTPD_MODULE)
diff --git a/ftp/proftpd/files/patch-modules_mod__tls.c b/ftp/proftpd/files/patch-modules_mod__tls.c
deleted file mode 100644
index b4c6104ba1d8..000000000000
--- a/ftp/proftpd/files/patch-modules_mod__tls.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- modules/mod_tls.c.orig 2017-01-16 01:13:01 UTC
-+++ modules/mod_tls.c
-@@ -609,7 +609,7 @@ static void tls_diags_cb(const SSL *ssl,
- break;
- #endif
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- case TLS_ST_OK:
- #else
- case SSL_ST_OK:
-@@ -633,7 +633,7 @@ static void tls_diags_cb(const SSL *ssl,
-
- ssl_state = SSL_get_state(ssl);
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- if (ssl_state == TLS_ST_SR_CLNT_HELLO) {
- #else
- if (ssl_state == SSL3_ST_SR_CLNT_HELLO_A ||