aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2006-06-10 03:01:14 +0800
committerdelphij <delphij@FreeBSD.org>2006-06-10 03:01:14 +0800
commit68ec4aad7bceabecd1387376ab773bbeca5c6a9f (patch)
treed0590e21ae722da33f53753a432aefdb5421454a /ftp
parent8dbadfbbcc80fa6fc1a7af7182786e88436c4d9c (diff)
downloadfreebsd-ports-gnome-68ec4aad7bceabecd1387376ab773bbeca5c6a9f.tar.gz
freebsd-ports-gnome-68ec4aad7bceabecd1387376ab773bbeca5c6a9f.tar.zst
freebsd-ports-gnome-68ec4aad7bceabecd1387376ab773bbeca5c6a9f.zip
Add an new option to provide a mechanism for users to disable kqueue
support if necessary. Submitted by: Kirk Strauser <kirk daycos com> Approved by: maintainer
Diffstat (limited to 'ftp')
-rw-r--r--ftp/pure-ftpd/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index 5a1d4e5c4a8b..d191f659949b 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pure-ftpd
PORTVERSION= 1.0.21
+PORTREVISION= 1
CATEGORIES= ftp ipv6
MASTER_SITES= http://download.pureftpd.org/pub/pure-ftpd/releases/ \
ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/ \
@@ -47,7 +48,8 @@ OPTIONS= LDAP "Support for users in LDAP directories" off \
THROTTLING "Bandwidth throttling" off \
BANNER "Show ${PORTNAME} welcome upon session start" on \
UPLOADSCRIPT "Support uploadscript daemon" off \
- UTF8 "Support for charset conversion (expreimental)" off
+ UTF8 "Support for charset conversion (expreimental)" off \
+ SENDFILE "Support for the sendfile syscall" on
.include <bsd.port.pre.mk>
@@ -115,6 +117,12 @@ USE_ICONV= YES
CONFIGURE_ARGS+= --with-rfc2640
.endif
+.if defined(WITH_SENDFILE)
+CONFIGURE_ARGS+= --with-sendfile
+.else
+CONFIGURE_ARGS+= --without-sendfile
+.endif
+
.if ${OSVERSION} > 500000
PAM_TEMPL?= ${FILESDIR}/pam.conf.5
.else