aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-05-23 01:52:50 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-05-23 01:52:50 +0800
commit80398207ca6945e9c440f04cef2b2cec03c56645 (patch)
treecb9fcab43c30078cc7c1a87736947463ae62e778 /ftp
parent30cc73f65758f1d5710c8dbdd9d38732fa72e182 (diff)
downloadfreebsd-ports-gnome-80398207ca6945e9c440f04cef2b2cec03c56645.tar.gz
freebsd-ports-gnome-80398207ca6945e9c440f04cef2b2cec03c56645.tar.zst
freebsd-ports-gnome-80398207ca6945e9c440f04cef2b2cec03c56645.zip
- Fix NSS option
- Bump PORTREVISION PR: ports/189987 Submitted by: ashish
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 6c9e2b17f75d..ab3dac25a35a 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.36.0
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -106,8 +107,9 @@ LIBSSH2_CONFIGURE_OFF= --without-libssh2
LIBSSH2_CONFIGURE_ON= --with-libssh2=${LOCALBASE}
LIBSSH2_LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
NSS_CONFIGURE_OFF= --without-nss
-NSS_CONFIGURE_ON= --with-nss=${LOCALBASE}
+NSS_CONFIGURE_ON= --with-nss=yes
NSS_LIB_DEPENDS= libnss3.so:${PORTSDIR}/security/nss
+NSS_USES= pkgconfig
OPENSSL_CONFIGURE_OFF= --without-ssl
OPENSSL_CONFIGURE_ON= --with-ssl=${OPENSSLBASE}
OPENSSL_CPPFLAGS= -I${OPENSSLINC}