aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-06-25 01:21:30 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-06-25 01:21:30 +0800
commit8d55b366522f467a22d8bff812f317f3670849d0 (patch)
tree04c304d7f07dd1926e5189458474a1f19b108b06 /ftp
parent6be3b5d48f3a5b3bfb57e60b8a950b3e7ffe8f36 (diff)
downloadfreebsd-ports-gnome-8d55b366522f467a22d8bff812f317f3670849d0.tar.gz
freebsd-ports-gnome-8d55b366522f467a22d8bff812f317f3670849d0.tar.zst
freebsd-ports-gnome-8d55b366522f467a22d8bff812f317f3670849d0.zip
Prevent building a broken curl when using the openssl port when GSSAPI_BASE set.
Without this curl would link to both /usr/lib/libssl.so and /usr/local/lib/libssl.so resulting in a crash at runtime. Bump revision as current builds are broken at runtime and need to be rebuilt. PR: 200555 Submitted by: truckman Approved by: maintainer timeout
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index eee4fb9589fa..3a082ae4da82 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.43.0
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -161,11 +162,14 @@ IGNORE= only supports LDAPS with SSL
IGNORE= only supports LIBSSH2 with OpenSSL
.endif
-.if ${PORT_OPTIONS:MOPENSSL} && defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
+.if ${PORT_OPTIONS:MOPENSSL} && ( \
+ defined(WITH_OPENSSL_PORT) || \
+ (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so)) || \
+ (defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"))
.if ${PORT_OPTIONS:MGSSAPI_BASE}
-IGNORE= with GSSAPI_BASE, configure failed to detect OpenSSL/LibreSSL from ports and link against base OpenSSL
+IGNORE= with GSSAPI_BASE, configure failed to detect OpenSSL/LibreSSL from ports and links against base OpenSSL
.endif
-.if ${PORT_OPTIONS:MTLS_SRP}
+.if ${PORT_OPTIONS:MTLS_SRP} && defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
IGNORE= unsupported TLS-SRP in LibreSSL
.endif
.endif