aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
committermat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
commitb2012f72500300ecbba6933c68717ba52c454563 (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /ftp
parente02e32ae84bd96a47a379dcd2c109efc58b41400 (diff)
downloadfreebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.gz
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.zst
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Diffstat (limited to 'ftp')
-rw-r--r--ftp/py-pyftpdlib/Makefile4
-rw-r--r--ftp/py-sftp/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/ftp/py-pyftpdlib/Makefile b/ftp/py-pyftpdlib/Makefile
index dfd757c0060c..25a17b3235c1 100644
--- a/ftp/py-pyftpdlib/Makefile
+++ b/ftp/py-pyftpdlib/Makefile
@@ -21,8 +21,8 @@ OPTIONS_DEFAULT= SENDFILE OPENSSL
SENDFILE_DESC= Enable sendfile(2) support
OPENSSL_DESC= Enable FTP over SSL/TLS (RFC4217)
-SENDFILE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pysendfile>0:net/py-pysendfile@${FLAVOR}
-OPENSSL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${FLAVOR}
+SENDFILE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pysendfile>0:net/py-pysendfile@${PY_FLAVOR}
+OPENSSL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
PORTEXAMPLES= *
diff --git a/ftp/py-sftp/Makefile b/ftp/py-sftp/Makefile
index 7e7609f863f2..7ff32e8cc9bd 100644
--- a/ftp/py-sftp/Makefile
+++ b/ftp/py-sftp/Makefile
@@ -12,7 +12,7 @@ COMMENT= Simple interface to SFTP
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.17:security/py-paramiko@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.17:security/py-paramiko@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils autoplist